unable to earn zsilver today

Discussion in 'Razer Cortex' started by ArsonGX, Jan 3, 2018.

Thread Status:
Not open for further replies.
  1. NebulaMask

    NebulaMask Active Member

    Same here, thought it was just me, logged out then back in, uninstalled and reinstalled cortex to no avail. I was able to earn some for a short period earlier today, but for the vast majority of the day it hasn't been showing any games earning zsliver.

    What's odd is that it shows the games as earning under the rewards tab in cortex, just not on my games page. Running games from the rewards tab still doesn't earn any zsilver though : /

    [​IMG]
    [​IMG]
     
  2. Killemagain

    Killemagain Member

    Yup, same here.
     
  3. Skrunch

    Skrunch Active Member

    I thought it was just me. I also haven't been able to earn any zSilver today.
     
  4. KylarFI

    KylarFI Member

    Having issues too. when i had played Starcraft 2 this morning it had said that it was earning silver. I stopped playing about 2 hours later and it gave me an error. Now it won't give the earning silver pop up when i load games.
     
  5. shmekermeister

    shmekermeister Well-Known Member

    Same here. Tried both Dota 2 and Starcraft 2, but no zSilver earned. And both times I got the same error as you guys.

    Probably some issues with Razer servers. It couldn't be coincidence that so many people have issues with Cortex at the same time. This didn't happen before (as far as I can remember).
     
  6. RazerSapiyo

    RazerSapiyo Community

    freakydoctor and ArsonGX like this.
  7. KrisxBell

    KrisxBell New Member

    annnnnnnnnd it's down again xD hopefully this will be all fixed very soon.
     
    OmnipotentXK, FiszPL and AverageLaugh like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >