Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Unable to use external monitor over HDMI or USB-C adapter on Manjaro Linux (Razer Blade mid 2019)

Discussion in 'The Linux Corner' started by PapistPenguin, Jul 23, 2020.

  1. PapistPenguin

    PapistPenguin New Member

    I have a Razer Blade mid 2019 Base, and I am trying to use an external monitor either through the HDMI port or a USB-C to HDMI port. However, neither work, which I find especially strange for the USB-C adapter since that should be just outputting from the iGPU anyways. I'm using GNOME edition and the default drivers MHWD installed, which is video-hybrid-intel-nvidia-440xx-prime.
    Given that this laptop has its HDMI port attached to the Nvidia card, I figured Intel exclusive mode would not work. So I tried using Hybrid and Nvidia mode in Optimus Manager. Hybrid mode makes no difference and switching to Nvidia mode only turns off the laptop's monitor, which I'm guessing happens because the Intel drivers get turned off.
    Is there anything else to try? Has anyone gotten this laptop working? Thanks!
     
  2. PapistPenguin

    PapistPenguin New Member

    So, I was able to figure it out. When I posted this, I could not get the display manager to work. I was using prime drivers, I think, trying to make Optimus Manager work. Also, I was using kernel 5.7.9-1. So, I started by undoing everything, just to get a display. I think part of it was a GNOME issue, since I did not have so many issues with Optimus Manager on XFCE, but that is little more than speculation.

    I started by undoing what I had done. So, I uninstalled Optimus Manager (sudo pacman -Rnu optimus-manager optimus-manager-qt) and replacing gdm-prime (which is recommended for Optimus Manager to work) (sudo pacman -S gdm libgdm).
    I also uninstalled all NVIDIA drivers. This at least allowed me to get back to a GUI (sudo mhwd -r pci video-nvidia-[insert version specific ending here]). (If unsure, input mhwd -li to find your specific driver.)

    By the way, if you are stuck with no display manager upon boot-up, use CTRL-ALT-F2 to get to a console to do all this. If you do not have access to a known wireless network (like in my case), then use ethernet to connect to the Internet.

    Finally, I made sure to clear out X11 (note the capital 'X' if you have trouble navigating to it in the terminal) conf files and to re-edit back any other files I had edited. Though, while this is what I did, I am not sure how necessary or advisable it is for other situations.

    After a reboot, everything was back to its unsatisfactory normal. I had found in one of the posts I had read about a tool called Optimus Switch by dglt1. This is what worked for me!

    If you have GNOME like I do, then use his optimus-switch-gdm package. I do not think it is in the AUR, but it is made for Manjaro Linux. His instructions are pretty good. I just followed them.

    I will note, however, that his guide says at a certain point: "You should see a list of various acpi calls, find the one that says “works!”". In my case, I had two that worked. However, one of them matched the one already listed in the script that you need to uncomment, so I just left the script as-is after uncommenting the suggested lines.

    After that, it worked really well. I can easily switch between Intel and NVIDIA GPUs. I can use HDMI for BOTH video AND audio! And the USB-C port works for audio. I highly recommended the GUI he mentions. It makes switching that much easier.

    If anyone else is struggling with something like this, feel free to message me. I'll answer if I have an idea on how to solve or have the time. Also, make more posts in Razer's Linux Corner forum.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >