Bluetooth issues on new Atheris

Discussion in 'Razer Support' started by xRuhRohx, Apr 20, 2018.

Thread Status:
Not open for further replies.
  1. xRuhRohx

    xRuhRohx Member

    Just got my Atheris in the mail today and connected it to my laptop via BT.
    Worked great. Came back later and turned my laptop back on and mouse connected again just fine.
    This time the mouse was glitchy. Turned it off and back on, still glitchy. Tried with the dongle and still glitchy, but worse. I went into the settings and removed the mouse from the PC. Tried to reconnect via BT and my laptop could no longer find it. Rebooted PC and still cannot find it. The PC can find all the other devices in the house. My Razer phone also finds all the devices in the house including my PC but it also cannot find the mouse.

    Not sure if there is an issue that has an easy fix or if I need an RMA already.
     
  2. FirePenguin

    FirePenguin Well-Known Member

    Yo! Have you tried putting the mouse in pairing mode? If not, try to push the slider under the Razer Atheris to Bluetooth mode, and then press and hold the 2 side buttons and the DPI cycle button simultaneously for 3 seconds to activate pairing mode. The LED indicator should blink twice in repeated intervals to show that the device is in pairing mode.

    *Moving to the Support section.
     
    xRuhRohx likes this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >