Fans turn on even when processor is not doing anything (Razer Blade Pro 2017 17")

Discussion in 'Razer Support' started by sniperman775, Jun 15, 2018.

Thread Status:
Not open for further replies.
  1. sniperman775

    sniperman775 New Member

    I've tried everything to resolve the issue. I've updated all my drivers, reset my OS, fiddled with temperature controls in the BIOS menu, opened my computer and dusted the fans, but to no avail. Customer support says that it must be a hardware issue and that I must send my computer in for a fan replacement. It will cost $160 minimum and would make me unable to use my computer for days. I manually removed the power from the fans because the sound was so loud that I couldn't study (finals week). I'm keeping a close eye on the temperatures, and obviously I can't do anything strenuous. So I have a few questions:

    Would replacing the fans even work? They're both malfunctioning, which leads me to believe something else is the culprit?

    Are there any third party fans that are compatible with the computer, so that I can replace it myself for cheaper?

    Are there any other suggestions on how to resolve the issue?

    Thanks so much for the help!

    Edit: Typo, I have the 2016 model
     
  2. AssembIer

    AssembIer Active Member

    Do you have an external screen connected to the Blade Pro ?
     
  3. sniperman775

    sniperman775 New Member

    No, just the laptop
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >