Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Have you upgraded to Windows 10?

Discussion in 'Systems' started by popbobtai, Jul 30, 2015.

?

Have you upgraded to Windows 10?

  1. Yes

    62 vote(s)
    61.4%
  2. No

    39 vote(s)
    38.6%
Thread Status:
Not open for further replies.
  1. jianzhou

    jianzhou Active Member

    upgraded for few weeks, so far no problem and better compare to window 8 ...
     
  2. Neutrinos

    Neutrinos Active Member

    I'm sticking with windows 7, I don't really like the new interface.
     
  3. crawlspace2

    crawlspace2 New Member

    Because I wanted to, backup imaging the primary and recovery partition ended up being the real challenge to the whole process. Once I was satisfied there, I used the Win10 update tool to initiate the upgrade process. While the download didn't take too long, the update itself took forever. About half-way through the update I had to click through Synapse installer to continue. Finally got to the desktop after what seemed several hours. Followed the sequence from Razer for updating drivers, and everything's been smooth sailing since.
     
  4. tztristan

    tztristan New Member

    Waiting for more details on win10 b4 upgrading!
     
  5. Fr3ddy

    Fr3ddy New Member

    Hello mmogaming

    I have the same Problem i tried to upgrade my Blade Pro (2012) to windows 10
    i lost the complete Switchblade UI the trakpad works but i can't get any apps.
    I installed windows 7 back same problem

    hope anyone can help
     
  6. Yaki1337

    Yaki1337 New Member

    jep and i have no problems. It fixed my chrashs in FF14 and Witcher 3. Everytime i go from fullscreen to desktop their was an 50% crash chance. With win 10 its gone!

    Only my firefox doesnt work well, but this is a firefox problem^^
     
  7. SkyweregamingNL

    SkyweregamingNL Active Member

    I'm going to wait it out for a while, Win 7 still runs perfect :D
     
  8. mmogaming

    mmogaming New Member

    Ok I finally did something and "it worked". Do not ask why it did.

    I went into device manager and uninstalled "Razer Blade" from there. I then uninstalled Razer Syn 2.0.

    I did not reboot, I went ahead and reinstalled Syn 2.0 (downloaded the latest version).

    I rebooted and finally it all worked.

    Post here if you need more details/etc.
     
  9. jj1216

    jj1216 Active Member

    Don't anyone experience like keyboard not working, wifi connected but no internet access and extremely lag and slow performance? Also I noticed that the start menu is really slow and only pop up after like 5 seconds
     
  10. hyperblaze14

    hyperblaze14 New Member

    It is not the best idea since it is still in development of beta and the client support is poor but if you have a good system and your mothercard is prepared it is less dangerous
     
  11. Link68759

    Link68759 New Member

    I have the 14" razer blade from 2014, and a clean install of 10 has DPC latency issues. Following the razer 10 upgrade guide reduced the severity and frequency, but it is still here. This is pretty annoying- if anyone has ever dealt with dpc latency in the past you know it's the most frustrating problem you can have.

    Anyone else in the same boat, any thoughts on how to fix this?
     
  12. ALKitten

    ALKitten Member

    I have a shit hp laptop, so I don't really care what happens to it, so I got windows 10 day one, even without the notification telling me to do so, but soon I might be purchasing a razerblade with windows 10!
     
  13. DespotarG08

    DespotarG08 Active Member

    I upgraded from 8.1 and well I have 0 issues on windows 10 which is fun
     
  14. MongoosePanda

    MongoosePanda Active Member

    I upgraded my laptop but kept having issues updating drivers for AMD.

    Didn't wanna try to upgrade my gaming desktop and have the same issue. :|
     
  15. bjungbauer

    bjungbauer New Member

    I'm having this issue as well. I have a 2012 R2 and have done a clean install of Windows 10 and tried the steps that worked for you. The switchblade UI refuses to work. If I use a windows 8 restore media the UI works fine. Clearly there is a conflict I just can't seem to find it.
     
  16. mmogaming

    mmogaming New Member

    Ok questions:

    1. When your PC boots up, does Syn start up?
    2. All other items work? (razer mouse, etc.)
    3. Macros work?

    For the UI, try to uninstall the driver for it again. Uninstall synapse (everything associated with it, mouse, core, etc.)and then go into control panel and uninstall all synapse products as well (razer blade, mouse, etc.)

    Then reboot and start the synapse install. Give it a go, I had to do this on my razer laptop and on my desktop for my mouse/keyboard.
     
  17. bjungbauer

    bjungbauer New Member

    1. Yes it starts up fine and says it is synching with the cloud.
    2. All appear to, including my naga and kraken.
    3. I don't have any macros recorded presently.

    I'll try uninstalling again. I noticed that with Windows 10 it does not appear to be installing core, only synapse and the synaptic touchpoint software.
     
  18. KingOfAngel

    KingOfAngel New Member

    Yes i have upgrade to windows 10 Beta With Windows Insider before the real version.
     
  19. mmogaming

    mmogaming New Member

    Yes, it is strange but the Core does not install. That may be a bug? I do not have it and so far seems to be fine.

    Anyone else notice this in Windows 10?
     
  20. bjungbauer

    bjungbauer New Member

    OK, I have uninstalled and reinstalled synapse numerous times. I noticed that there are 2 locations where "Razer Blade" appears in device manager, under Human Interface Devices and also under Universal Serial Bus Controllers. I have uninstalled these, being sure to check the box to remove the driver, as well as uninstalled synaptic and synapse both with rebooting after uninstalling and not rebooting before reinstalling synapse. In every case synapse reinstalls and updates, then after reboot loads and says synching yet the switchblade ui never initializes.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >