Is fighting against Synapse 2.0 & 3.0 normal ?

Discussion in 'Razer Support' started by Skaeryon, Jun 23, 2018.

Thread Status:
Not open for further replies.
  1. Skaeryon

    Skaeryon New Member

    Hello,

    I possess :
    -1 Razer Lancehead wireless (I use it only for FPS games),
    -1 Razer DeathAdder 2013 (I use it to browse on my computer and gestion games etc),
    -1 Razer BlackWidow Ultimate.
    -I also have two Razer mouse pads.

    All of it combined must be close to 300€.

    I've been having this bug with my Synapse 2.0 recently : it won't open, while being in the task bar.
    I've been trying a lot of things, uninstalling, suppressing, cleaning every Razer documents etc etc.

    (I heard it was Razer Surround or something, that messed things up.
    I didn't even know it was installed on my computer, and right now, I'm not even sure it was. This problem is such a clusterfuck that I can't even fathom wtf is going on.)

    So,
    At some point, I got my Razer Synapse 2.0 back and working just fine.
    But it couldn't detect my Lancehead anymore.
    At this point I also had the Razer Synapse 3.0 installed, who WAS detecting my Lancehead, but nothing else !
    I bought for hundreds of dollars worth of products and a brand new software made by the same company, can't detect them ?
    Is this a way to push me to buy more recent products ? That's a bloody cheap move.
    The same goes for my DeathAdder, that I still use for other games than FPS. Synapse 3.0 couldn't detect it.

    I tried different things to get my Synapse 2.0 to detect again my Lancehead, like uninstalling the device etc etc, but nothing worked.
    While it was detected on a fucking nano second the first time I plugged it a few weeks ago.

    After hours of trying different things, and nothing worked, I decided to uninstall and reinstall once more.

    Now my Synapse 2.0 can't be opened, as before, and my Synapse 3.0 WON'T EVEN OPEN, in the same way Synapse 2.0.
    So I can't even know if that fucking software WILL or WILL NOT detect my Lancehead again. Of if it will, someday, detect my older stuff.
    I tried to uninstall & reinstall this 3.0, to no avail. Nothing works. It only "worked" once and I can't get back to this state.

    So let me ask you this question :

    At what point, is anything of this acceptable for a company ? You make me want to throw away all this garbage and spend my money elsewhere.

    That beta can't be even an excuse, because, for a program to be on beta, it first has to work at least a little bit.

    I shouldn't have to play the computer scientist a fucking Saturday afternoon to get a little supporting software working, especially when its linked to hundreds of euros products.
    I just wanted to play a few games, and this is where I end up a few hours later. Defeated and pissed off, with no support software working for the stuff I bought for hundreds of euros, and crybabiing of this forum.

    Now I'm fucked, I don't know how I'm going to find my sensi back while playing my games, and spent my Saturday afternoon trying to fix a problem when it's not my job, and didn't have any result to show for it.

    Nice work.
     
  2. Razer.Winteryang

    Razer.Winteryang Ice Bear

    Hi @Skaeryon! I sent you a PM so we can work this out. Feel free to respond anytime.
     
  3. pulseOrangePeel172

    pulseOrangePeel172 New Member

    Greetings,

    I am having similar issues entirely. I had my BlackWidow Chroma V2 and Naga Chroma attached and working perfectly fine, I had my profile from the chroma workshop that I spent hours tweaking to my liking and it was working perfectly, I was questioning going to Synapse 3 since they are recent devices that could benefit from the better one, I installed it, ran through setup, tried to export my profile to import it, it doesn't even recognise the normal file type that SYNAPSE exported in. Oh well, tough luck, I uninstalled completely Synapse 3.0, the way I uninstall everything else, methodically, removing every change and trace, then a few weeks later, due to another unknown issue where my games are now crashing my PC, but only some games, and with no warning ( checked thermals, checked everything, ran stress test CPU, GPU, nothing is different. Again, unrelated issue to the Razer one I am about to explain. )

    Anyway, I will cut to it. After I got this issue, I ended up completely wiping Windows and all other programs off my Boot SSD, cleaned the drive of every file, then installed a fresh version of Windowes 10 on it after backing up my files to my NAS. It auto installed Synapse 3, and because I still had my backup profile, I uninstalled then installed Synapse 2. Now NONE of my Razer devices are detecting on Synapse. I have done the following:

    -Uninstalled and reinstalled synapse dozens of times, each time deleting all of my human interface drivers, each time removing changed registry keys, to make sure I completely removed the software
    -Nuked and paved again, completely wiping my SSD and reinstalling Windows in order to attempt to cancel the installation of Synapse 3. Successful, but Synapse 2 still did not detect any devices to find
    -Detached and uninstalled everything razer from my system, only to reboot, reconnect, reinstall, it detected the Naga, but it didn't let me do anything with it.

    Kindly help as best you can, I am frustrated beyond belief that this simply wont do the one thing it is designed to do. And could you answer on this forum? I find DM's important in certain scenarios, however I came here wondering what fix I could find, after scouring, even following a reddit post at https://www.reddit.com/r/razer/comments/4hyqog/synapse_not_detecting_anything/ to a tee. No luck for me.

    Thank you,
    Maxwell
     
  4. Razer.Winteryang

    Razer.Winteryang Ice Bear

    Hi there! Have you tried using it on a separate computer with a running Synapse 2 and observe any changes? If you haven't, please do so to further isolate things. Please update us via PM so we can assist you better.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >