Razer Blade 1060 Intel GPU problems on some apps

Discussion in 'Systems' started by bfgenis, Apr 14, 2017.

Tags:
Thread Status:
Not open for further replies.
  1. I uploaded a video to demonstrate the issue.

    This happens when i use my Intel Graphics as my primary GPU. If i disable Intel GPU and use Nvidia 1060 problem is solved but then i use the ability to change screen brightness and it's always on a max brightness.

    This happens on some apps when you maximize them, like Notepad++, and some apps that use old windows form libraries.

     
  2. RaptureHearts

    RaptureHearts Gamer Geek Girl

    Let our support team assist you with the problems you are having with your GPU. Contact our team at http://rzr.to/help so they can further assist you with your problem.
     
  3. Well, i already did. They suggested me an option that's not going to work for me! They wanted me to return the device, it's impossible to do that from a place where i live.

    So i'll leave it posted in YouTube and here because there's likely that someone might have solved the problem or will solve it, since this is only software related problem.
     
  4. Joikansai

    Joikansai Well-Known Member VANGUARD

    It's optimus related problems i think, try update your intel graphic card using intel driver update tool here
    http://www.intel.com/content/www/us/en/support/detect.html
    It happened also to my old Blade 2015 once, but it was when i have to input my login password, solved with those graphic update.
     
  5. I have latest Intel GPU drivers. I know it's not Optimus related because even if i disable Nvidia 1060 completely the behavior remains the same.
     
  6. DennisB88

    DennisB88 New Member

    I have the same problem. It has to do something with the PSR option on the intel graphics...
     
  7. No, that is an easy fix. This is something lot more complex, feels like Intel driver is failing and trying to recover all the time!
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >