Razer Deathadder Chroma help?

Discussion in 'Mice and Surfaces' started by Skullavidge090592, Nov 10, 2017.

Thread Status:
Not open for further replies.
  1. Skullavidge090592

    Skullavidge090592 New Member

    Hi all,

    Just looking for a bit of help, not sure if this is the right place to be posting this if not please direct me to correct location.

    So I have a Deathadder Chroma, love the mouse think it's amazing. I'm having a slight issue though, when I'm playing Dota2 every now and again the mouse becomes completely unresponsive. The chroma lights are still on the logo and the wheel however the mouse just stops working. I have to quickly unplug it and plug it back in for it to work again. The weird thing, this ONLY happens when playing Dota2. I can play multiple hours of PUBG and many other games and not face this issue, Dota2 however? Very often this problem occurs.

    Just wondering if anyone else has faced this issue with the mouse and any workarounds for it?
     
  2. mo-iro

    mo-iro Active Member

    Have you tried with another mouse, a cheap one, just to see if it still happen playing dota?
     
  3. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Contact Razer Support. They can help you figure out if it's an issue with your system or your mouse.
     
  4. FiszPL

    FiszPL Well-Known Member

    Saw your previous post about Synapse issue, and I think, that it's an OS problem or some app is causing this. Try to scan your PC with some AV/Antimalware, and clean up.
    Are you running administrator account, or you're login as a "normal" user?
     
  5. Hucast

    Hucast Well-Known Member

    That's what I would do. Razer's CEO had me contact the Cortex team in the past and they solved my problem. I'm actually using them right now because I have an issue with Cortex. I e-mailed them on the 8th and I got a reply the next day. Not its just a matter of following the instructions provided.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >