Razer Keyboard Spectrograph - Audio Visualizer [WIP]

Discussion in 'Razer Chroma' started by CalcProgrammer1, Mar 10, 2015.

Thread Status:
Not open for further replies.
  1. 146008437

    146008437 New Member

    Mine works but is there any way to keep both cloud setting and this together.
     
    bloopploob likes this.
  2. CalcProgrammer1

    CalcProgrammer1 Active Member

    Hmm ok. The rainbow should slowly wave, but I think if OpenAL doesn't get an audio message it might hang? Not sure. The rainbow should be dim, it's dim so that the bright visualizer doesn't get washed out. I think this means your SDK is correctly set up.

    If you have a working Stereo Mix then you don't need VAC. Just set Stereo Mix as default and disable the VAC line.
     
  3. GrantSor

    GrantSor New Member

    So everything in my system is set up correctly. But why does it not work? Am I missing some apps?

    No waving rainbow, just static, super dim like you said, and only some white LED light up
    [​IMG]
     
  4. Verthaa

    Verthaa Active Member

    @CalcProgrammer1 You, sir, are amazing. I have been looking for something like this for a while (actually, a lot of people have been), and you just made our dreams come true. Great work!
     
  5. CalcProgrammer1

    CalcProgrammer1 Active Member

    I really have no idea at this point. Those were the things I did to make it work and it worked. The only other thing I can think of is that OpenAL needs to be installed properly rather than just sticking the .dll in with the .exe.

    Try downloading and running this installer:

    http://www.openal.org/creative-installers/oalinst.zip
     
    Ziki <3 likes this.
  6. GrantSor

    GrantSor New Member

    Well my friend, That solved the problem :)))))))
    EVERTHING IS WORKING WELL :)
     
  7. CalcProgrammer1

    CalcProgrammer1 Active Member

    Hmm, awesome! I guess that is what the divide between "it works" and "it doesn't work" users is. The people who have it working already had OpenAL installed. I'll edit the OP with that link.
     
    GrantSor likes this.
  8. CycloneJoker

    CycloneJoker New Member

    omggggggg its so coooooooollllll!!
    thanks for developing this CalcProgrammer-sama!
     
  9. pornmaster69

    pornmaster69 New Member

    Can't get it to work.. Been reading the comments, but I'm just too noob for this. :D
    I downloaded OPENAL, CorsairKeyboardSpectrograph-master, and FunBasAudio. I also set Stereo Mix to default. Still can't get it to work.. :slightly_sad:
     
  10. Caixote

    Caixote New Member

    nothing is working for me, and i dont have audio mixer
     
  11. Ergonyx

    Ergonyx Member

    So I got a little impatient and finally decided to sit down and get this bad boy working. Through hours of trial and error and a couple breaks to gather my thoughts because I was feeling like an idiot, I finally got it working! I also took a bunch of time to review my notes, do some prep, and make a step-by-step video tutorial that will hopefully have this up and running for everyone!

     
    iiaZyxAngel, Krompek and setik01 like this.
  12. HOLY MOLY, this is awesome, gonna try this with more songs ! :stuck_out_tongue_winking_eye: thank you
     
  13. ToxicSquirrelX

    ToxicSquirrelX New Member

    I set my stereo mix to default but it wont pick up sound.
    do i need to plug somewhere else?
    Ima buy the chroma tomorrow, this is what i been waiting for.
     
  14. Ergonyx

    Ergonyx Member

    This will only work if you already have the Chroma Keyboard. Once you get it tomorrow you can try again :blush:
     
  15. PhysX-

    PhysX- Member

    finally its work ! thank you
    and thank you @
    CalcProgrammer1
     
  16. ZulfaidhiYazab

    ZulfaidhiYazab New Member

    I dont even know how... can you do a video tutorial?
     
  17. PhysX-

    PhysX- Member

     
    ZulfaidhiYazab likes this.
  18. zachary_quek

    zachary_quek New Member

    thx for this effect now my keyboard is very cool because of you
     
  19. xAnWx

    xAnWx New Member

    Weird. When I run FanBusAudio, the window auto close. I don't even have the chance to move the window. What problem am I facing?
     
  20. dariusmizuro

    dariusmizuro New Member

    hi calc it seems that some how your program work but its funny its not recording the music and emit the effect. when i change my task it only lights up when i change programs. do you know what is the problem?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >