Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Nari beeping even when fully charged

Discussion in 'Razer Support' started by Taiiw, Oct 15, 2018.

Thread Status:
Not open for further replies.
  1. Taiiw

    Taiiw New Member

    Hi, I just got my Razer Nari (Standard version not Ultimate) and about 2 days ago it started beeping out of nowhere ever since 3 days ago every 2 to 3 minutes depending on the battery percentage. At first I thought it was because it was low on battery because I am using it wireless. I charged it but it kept doing it while it was charging too. I kept letting it charge overnight. The next day I got on my PC and it was still doing it. I tried reinstalling Synapse 3 twice. Does anybody know what might be causing this?

    Actually nvm I fixed it.
     
    Last edited by a moderator: Oct 17, 2018
  2. what was it, mine is doing this also?
     
  3. epidemicrainbows

    epidemicrainbows New Member

    i am having the same issue please help.
     
  4. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    If you're on wireless mode, try plugging the USB dongle directly on different 3.0 ports. If the problem persists, please send me a PM and I'd be happy to help you further isolate.
     
    flenn15, stavely2 and ASSHOE like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >