Razer wallet issue

Discussion in 'Razer Support' started by Tenkou, Dec 7, 2018 at 7:40 AM.

  1. Tenkou

    Tenkou New Member

    Hello, I am experiencing a problem regarding the use of razer gold website. The website notified me that I do not have a wallet. So I followed the steps it showed me until I am required to confirm my region. I confirmed it and nothing happened after it shows me a 'tick' sign but it still notifies that I do not have a wallet. So I tried relogging my account and unfortunately nothing changes. I believe this is the website having a problem?.. because I do not seem to have any issues regarding my internet connection
     
  2. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hi there. Can you post a screenshot of the issue? Also, have you tried to contact Razer Gold support?
     
  3. Tenkou

    Tenkou New Member

    As in the screenshot i attached. You can see that I have confirmed my region "Malaysia" and it shows me the tick sign which I assume to be as "confirmed". But the problem occurs when no matter if I relog or not, my account keeps informing me that I have no wallet with Razer as if you look on the top right of the website.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >