[SUPPORT] RAZER Synapse 2.0 Continually updates...

Discussion in 'General Discussion' started by SteeleGamer97, Jan 10, 2015.

Thread Status:
Not open for further replies.
  1. SteeleGamer

    SteeleGamer New Member

    I start synapse and than it asks to update, but after it updates it asks to do the same update. I can't customize my peripherals. I have tried restarting my PC, uninstalling and reinstalling, And repairing the software. I can't seem to find the fix! Can someone help? I have a razer BlackWidow Ultimate 2013, Razer Naga MMOG 2009, And a Razer Kraken 7.1 Chroma.
     
  2. yannickverc_no_id

    yannickverc_no_id Active Member

    Have you tried to use a different mouse/keyboard to install the software and then connect the periphirals once synapse is installed?
     
    rosskyo likes this.
  3. SteeleGamer

    SteeleGamer New Member

    tried but then it updates every time still
     
  4. yannickverc_no_id

    yannickverc_no_id Active Member

    Then I'm afraid I can't help you. You'l either have to wait for a response from devs here or email their support :)
     
  5. njbmartin

    njbmartin Developer of Awesome

    do a complete uninstall of everything Razer and reinstall it. Tends to do the trick.
     
  6. SteeleGamer

    SteeleGamer New Member

  7. onetruevu

    onetruevu New Member

    I get that constant update reminder as well. It's pretty annoying honestly.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >