Synapse 3 no longer works since last update

Discussion in 'Razer Support' started by timebuilding, Aug 13, 2018.

Thread Status:
Not open for further replies.
  1. timebuilding

    timebuilding New Member

    i got a razer ornata chroma a few weeks ago, and it was working with synapse 3 just fine, until an update a couple of days ago.

    after the update, i lost my programmed keys, and the lighting effect is back to default. (typing on this keyboard with the light cycling through the spectrum of colours is hurting my eyes and giving me a headache!)

    when i tried to open synapse 3 to reset my preferences, but i couldn't get a visible window. i could see it running in the background though, just no way to interact with it.

    i ended up uninstalling the software, and they installing the currently available download. now i get a synapse window that says "failed to start" and the retry button underneath won't work.

    so i got the software to run the repair on itself, and that took me back to only seeing it run in the background without an accessible/visible window.

    so once again, i uninstalled and then reinstalled, and am back to getting the "failed to start" window... and the lighting i'm suck with is driving me nuts!!

    how do i fix this?!?
     
    YouKnowHens and pancholr like this.
  2. agentbadboy028

    agentbadboy028 New Member

    same problem.. can install it again..
     
  3. YouKnowHens

    YouKnowHens New Member

    I'm relieved to hear that I'm not the only one with that problem. First I thought that something was wrong with my huntsman elite. So... I got the same problem too. Didn't uninstall tho, just hoped they would fix it in a future update. I have reported this as a bug 2 times for good luck.

    Razer. FIX THIS NOW!
     
  4. OtterMike

    OtterMike New Member

    So frustrated. I will never buy this crap again. The customer support is horrible. They don;t respond and the programmers must be on drugs.
     
    Lusabit likes this.
  5. timebuilding

    timebuilding New Member

    i opened a support ticket with razer 3 days ago, and as of yet, have not heard a thing from them.

    fingers crossed there's a fix soon!!
     
  6. Just bought a Tartarus V2 as an upgrade from an unbreakable Nostromo. Synapse V3 V1.0.83.111 is utterly broken. I can't get it to do anything. Big mess for Razer, not to mention trusting users. Grrr
     
  7. OtterMike

    OtterMike New Member

    I got mine working by uninstalling the program,deleting drivers, deleting synapses 3 registry using ctrl + R and typing regedit and searching for Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Razer\Synapse3 and reinstalling. Hopefully,it will work for ya'll. Note: I did delete everything I could find that had Razer on it. After reading so many articles I found the registry part which is what I believe fixed it.

    I did this first that they sent me as well but did not work. They can not remotely fix nothing so that is a no go.
    COMPLETE REINSTALL SYNAPSE 3
    Before clean reinstall, collect logs so we can take a closer look.
    Please zip the folder C:\ProgramData\Razer\Synapse\Logs and send over to us. Once this is done, proceed to clean re-install.
    1. Uninstall Razer both Synapse 2/3 from your PC if you have both installed and delete all files in C:\Program Files (x86)\Razer and C:\ProgramData\Razer directories.
    These folders are hidden by default, so please be sure to unhide them. We want to ensure that there are no residual files remaining that may corrupt your installation. This is important so please kindly do so. If you are not able to delete the folders, Restart your computer first.
    Click Start > Control Panel > Appearance and Personalization > Folder Options > View tab > Under Advanced settings > Show hidden files, folders, and drive > click okay.
    2. Uninstall the device drivers from the control panel > device manager, then unplug and re-plug Razer device (if there are any).
    3. Temporarily turn off all Firewall and Anti-virus software to prevent any conflicts.
    4. Then, install the latest version of Razer Synapse using the link: http://drivers.razersupport.com//in...iewdownload&downloaditemid=2731&nav=0,343,704
    Add Synapse/Razer folder to the exclusion list in Windows defender if you are using a Windows operating system after you have installed Synapse.
    5. Run the installer as administrator and run the program as administrator as well.
    6. Restart your machine and log back into your Razer account.
    7. Allow Razer Synapse to fully update, restarting when prompted.
     
    Predator5 likes this.
  8. Predator5

    Predator5 Well-Known Member

    Everyone, please submit your Synapse Logs to this thread.

    You should create a new thread with this info for all users experiencing those issues.
     
  9. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member

    Hey guys! Are you still having the same issue? Let me know through PM.

    Also, moving this to the support board.
     
  10. timebuilding

    timebuilding New Member

    i heard back from support in an email today, and they suggested i try doing one of the things i already mentioned i had tried!! (grrr.)

    i appreciate ottermike's suggestions, but we should not have to be going into our registries, etc.

    shouldn't razer just release a patch or something?

    i'd love to share my logs with you, but i do not see anything that says 'feedback' when i am in my razer id profile.
     
  11. I tried to tinker in Synapse today and it froze until I forced it to terminate. This happened several times.

    I'm actually relieved to learn this is a community-wide problem because I was worried for my computer's performance.
     
  12. Razer.RedPanda

    Razer.RedPanda Guardian of the Forest Staff Member


    If you can, please send your feedback through Synapse itself. You can also send your logs there.
     
  13. timebuilding

    timebuilding New Member

    i can't submit thru synapse... the parts i can get to don't have a feedback button.
     
  14. Errrm, it's right there, huge, top right on the Synapse V3 dashboard page, in caps, named BETA FEEDBACK...
     
  15. Predator5

    Predator5 Well-Known Member

    You cant get to this part?

    beta.jpg
     
  16. timebuilding

    timebuilding New Member

    what i get does not look like that. i took screen shots, but don't know how to attach them here.

    in razer central, i get a window with 'razer id', 'notifications', and 'apps' at the top. under that i see 'profile' and 'account'. i do not see anything about devices or modules.

    in razer synapse, i get a window that says 'failed to start'. under that there's a 'retry' button... and under that a 'get help' link that takes me to https://support.razer.com/software/synapse-3
     
  17. Predator5

    Predator5 Well-Known Member

    Oh... the screenshot if of Razer Synapse not of Razer Central. You can attach them using the "Upload a File" button next to the green "Post Reply" button when writing a post, then you can click on "Full Image" if you want to display it how I did.
     
  18. timebuilding

    timebuilding New Member

    for what it's worth... the last update corrected the problem. thanks.
     
    Predator5 likes this.
  19. German_Hawkeye

    German_Hawkeye New Member

    Srsly to start the UI, i have ti go to Task Manager: Kill Razer Synapse and Kill Razer Synapse Service (32 Bit), then start the Synapse Software as Administrator.
    In my opinion Synapse 3 is crap.
     
  20. timebuilding

    timebuilding New Member

    there's an even newer update now, and i'm afraid to apply it. everything is working just fine right now, and i'm worried the update will mess things up again...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >