Synapse for macOS Sierra still broken

Discussion in 'General Discussion' started by Deleted member 347606, Sep 30, 2016.

Thread Status:
Not open for further replies.
  1. Synapse for macOS from today downloaded, still not able to configure Naga Epic Chroma mouse.
     
    NecroZek likes this.
  2. RaptureHearts

    RaptureHearts Gamer Geek Girl

    Try doing a clean install for your Razer Synapse. If that does not resolve it, contact our software support team through http://www.razersupport.com/contact-us. Our team will be able to assist you.
     
  3. Thank you for the fast response. It was a complete clean install. No way to assign any keyboard commands to the any mouse button.
     
    NecroZek likes this.
  4. everMossGreenx517

    everMossGreenx517 New Member

    The latest Razer Synapse (v1.59) installs perfectly on MacOS Sierra, but crashes when connecting a Razer Naga MMO Gaming Mouse on the USB port. I tried the update on two computers, a late 2015 iMac, and a 2015 MacBook Air with identical results. Please fix it!
     
  5. TurnipUmbrella483

    TurnipUmbrella483 New Member

    Urgh.

    I had Synapse completely uninstalled prior to the 1.59 release (it was the only way to let my BlackWidow Chroma work). I downloaded the release today and installed it. And it works.

    Except...the lighting effects run at about a tenth of normal speed. Key bindings seem fine, status lights light up again, I can reprogram the Windows key to be my Mac's option key again. Great. But the lighting effects on the keyboard all run as if they're being controlled by a VIC-20; where before, I'd get nice smooth rippling effects when I pressed a key, now it stutter-steps the effect along the key backlights.

    And before anyone asks--yes, I started fresh. This is a new profile in Synapse, not imported from prior versions. And I removed all of the effects except the ripple and tried it that way. And I set the speed correctly. I made it as completely simple as possible, and it doesn't work correctly. The lighting effects are broken.

    But I can read, and I did read the other Sierra thread and the post about letting support know if there were issues. So I filed a ticket with Razer support to let them know. And I got this response:

    ...and a link to the now-closed thread about Sierra.

    So...let me see if I've got this straight. The Razer Insider forum says "Hey, go and download 1.59--it supports Sierra!". I do. I report that it has problems. And the response is "Sorry, it doesn't support Sierra."

    <insert Picard facepalm here>
     
  6. everMossGreenx517

    everMossGreenx517 New Member

    I got exactly that same automated response when I reported the issues I am having. I wasn't´t sure whether to be offended or just amused about it all. I do hope it gets resolved soon enough. Why didn't´t they worked on it while the beta was going, is beyond my comprehension.
     
  7. I tried installing the latest version of Synapse just now (a clean install), which says it's compatible with macOS Sierra 10.12. After the install and reboot, during the downloading of my peripherals, Synapse crashed (screenshot below shows the crash error.) I opened a case with Razer Support in the Contact Us page.

    ErrorScreenshot1.png
     
  8. It is not crashing on my system, but has problems and the configurator is extremely limited for Chroma X
     
  9. Coralfrontload008

    Coralfrontload008 New Member

    No kernel panics or other major issues here, but modifier keys no longer work in conjunction with the side buttons on the Naga.
     
  10. bensnook1

    bensnook1 New Member

    anyone know if the mamba TE works? because according to everyones posts my othr gear should be fine.
    thanks
     
  11. Devs, lots of issues on naga 2014 sometimes when you boot mouse doesn't turn on and when you reset the mouse with the three buttons (left, right and scroll click) at boot it starts but it takes another so synapse can finally show the mouse config.
     
  12. DarkTaninfodaily772

    DarkTaninfodaily772 New Member

    can we please get a razer representative here to update us on the the status of this? and if they are working on other bugs specific to sierra.
     
  13. Humana

    Humana New Member

    Kernal Panic again :c
     
  14. Same constant crashing of Synapse.

    Seemed like it was working fine, up until I had to to a clean install of Sierra today. Now I can't seem to install synapse :slightly_sad:
     
  15. Dylan_Ma

    Dylan_Ma Member Staff Member

    Hi everyone, it seems some of you are still facing issues with Razer Synapse. Could you try a fresh install of Razer Synapse. If the problem still persists, do drop a message to our Support Team and they will be able to assist you.

    I'll be locking this thread. If you require any further assistance, do feel free to contact me directly.

    Do note that Razer Insider is not a support forum.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >