USB Issues? HELP

Discussion in 'Razer Support' started by urbanWarmBlackAPATITE843, May 9, 2018.

Thread Status:
Not open for further replies.
  1. I've been having issues with my keyboard, mouse and headset.
    All 3 will randomly disconnect/freeze/become unresponsive.

    Keyboard: Razer Blackwidow Tournament Chroma (USB 1/2)
    Mouse: Razer Lancehead (Plugged into USB 3.0)
    Headset: Razer Kraken 7.1 V2 (Plugged into USB 3.0)

    It started happening when I realized that Razer Synapse 2.0 would not open at all, so I uninstalled it and installed Razer Synapse 3.0 instead. After 10 minutes, my headset, mouse and keyboard would freeze. It would happen roughly 10 minutes after switching my PC on everytime, so I uninstalled Razer Synapse 3.0 and I didn't re-install.

    It was OK for a few days then they all froze again. So I installed Razer Synapse 2.0, fully updated. However it continues to randomly freeze, more frequently when I have Overwatch/CSGO open and it uses a game theme, or one of my created themes, so I keep it on spectrum. It happens once every few days. I don't know what triggers it, sometimes it happens when I have nothing open.
    I use SlimDrivers to update all my software, everything is up to date apart from my BIOS which I am in the process of sorting out.

    When it freezes, the colours stop changing, I can't type or move, I can't hear anything and nothing pops up to say that a USB has been disconnected as it would when you unplug them. This just baffles me I have been looking everywhere but no one seems to have the same issue.

    A restart fixes it, but sometimes it take longer and once it freezed when booting on A2 motherboard code which it has never done before.

    Maybe this is a Razer issue, maybe not. I do not have any other keyboard/mouse/headset to test it on, but I could borrow one from a friend. Please, some advice on a fix?

    PC SPEC:
    Processor: Intel® Core™i7 Six Core Processor i7-6800K
    Motherboard: ASUS® ROG STRIX X99
    RAM: 16GB HyperX PREDATOR DDR4
    Graphics Card: 8GB NVIDIA GEFORCE GTX 1070
    Hard Disk: 480GB HyperX SAVAGE 2.5" SSD, SATA 6
    2nd Hard Disk: 2TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 64MB CACHE
    Processor Cooling: Corsair H60 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans
    Monitor: ASUS 27" ROG Swift PG278Q
     
  2. AssembIer

    AssembIer Active Member

    Do you plug in your devices directly into the board or on some ports of your case ?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >