Welcome to The Linux Corner!

Discussion in 'The Linux Corner' started by Deleted member 368765, Feb 27, 2017.

Thread Status:
Not open for further replies.
  1. tamashumi

    tamashumi New Member

    Hello folks. I'm running Ubuntu on a Stealth since a while (i7-7500U).
    It's Ubuntu 16.04 and I've got updated kernel to 4.14. Some weird things are happening.
    I've already managed to fix missing firmware for i915 and error message about outdated intel CPU microcode.
    I'm still having such an error though:

    [ 3.776351] tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x201] vs fed40080 f80
    [ 3.776418] tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x201] vs fed40080 f80


    Quite often when I reboot the laptop goes dead sleep instead of rebooting and it needs a hard reset (the power led flashes as it was in sleep mode). I think this error message is related to such behaviour. It seems to be due to an updated/incorrect BIOS. Are there any BIOS updated coming from Razer? I couldn't find any...

    @mefb90 could you (or anyone) please run a command: dmesg and see if there are any errors in the log for you on Kubuntu 17.10? (they should be highlighted red in a terminal)?

    I wonder when is this official linux support coming :rolleyes:
     
    Panaman likes this.
  2. Aureolinaerovine609

    Aureolinaerovine609 New Member

    kubuntu 17.10
    Dont hold your breath we are really not their target customer.

    no real problems with power management this is all I see on boot (dont think its real important):

    0.137124] ACPI Error: [_SB_.PCI0.RP05.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170531/dswload2-191)
    [ 0.137124] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170531/psobject-252)
    [ 0.137124] ACPI Error: Method parse/execution failed \_SB.PCI0.RP04.PXSX, AE_NOT_FOUND (20170531/psparse-550)
    [ 0.137270] ACPI Error: [_SB_.PCI0.RP09.PXSX] Namespace lookup failure, AE_NOT_FOUND (20170531/dswload2-191)
    [ 0.137278] ACPI Exception: AE_NOT_FOUND, During name lookup/catalog (20170531/psobject-252)
    [ 0.137285] ACPI Error: Method parse/execution failed \_SB.PCI0.RP08.PXSX, AE_NOT_FOUND (20170531/psparse-550)
     
  3. tamashumi

    tamashumi New Member

    @Aureolinaerovine609 oh, it's been almost a year since the "We'll make Razer the best linux laptop".
    I doesn't have to be the best but some support to solve issues wouldn't hurt.

    What kernel version are you at? Is there no screen blinking?
     
  4. Aureolinaerovine609

    Aureolinaerovine609 New Member

    Linux blade 4.13.0-32-generic #35-Ubuntu SMP Thu Jan 25 09:13:46 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

    The screen still blinks occasionally, it seems to be related to how "busy" it is but I wouldnt say it is a strong correlation.
    Im just happy I can make my keyboard colors change ;)
     
  5. Ploratus

    Ploratus New Member

    I have a Razer Chroma, Black Widow Chroma V2 (keyboards) and a Man O'War headset. $50.00 each plus shipping. I don't need Windows for my job anymore, so I am ditching it for a superior OS. No sense in having keyboards and Headsets that don't work. Hit me up if you are interested. I prefer to unload all of them at once. Thanks and good luck with your Windows Malware!
     
    amarok-blue likes this.
  6. kaljade

    kaljade New Member

    +1 on Arch distro, I'd go one step further and suggest Manjaro: https://manjaro.org which is an Arch based distro that has a very active developer community that are willing to add driver support into their kernel (I know as I'm upgrading from a Surface Pro 3 to a Razer Blade 14" and they had full driver support for Type Cover before it made it's way into the mainline kernel).

    Plus they are also green, so there's some synergies there too :wink_:
     
    Last edited: May 18, 2018
  7. tamashumi

    tamashumi New Member

    Whatever the distro or the distribution way, it's been over a year since the announcement.
    It would be good to see any linux support coming or at least some confirmation the idea hasn't been abandonned.
     
    kaljade likes this.
  8. I was just reading an article recently where a guy named "Min-Liang Tan" (appears to be the CEO) wants "Razer wants to bring the best-in-class Linux experience."

    This is great news! Here is one feature that you need to implement.

    If you want to properly support Linux, though, the most important step is to get rid of the Intel video altogether - Optimus is painful. There is probably no single technical problem that is more painful to deal with.

    In past years, some laptops had BIOS settings that would allow either all-NVidia, all-Intel, or Optimus. Please make sure to add this option in your next generation.

    Thanks
     
    ifohancroft and Panaman like this.
  9. xourge

    xourge New Member

    Hello, I tried installing Ubuntu 18 and 17, 18 froze at the beginning of installation, but 17 works fine.
    Tried installing optimus but it didn't work well and Ubuntu froze after logging in
    Using Aditional driver option to install nvidia worked fine. I cant switch between gpus using prime usually without any issues after reboot.
    I have a Razer Blade 2016
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >