Razer Blade RZ09-0165 Wont Boot, Cant access BIOS. Please Help.

Discussion in 'Razer Support' started by coolWindsorTanportal149, Dec 19, 2018.

Thread Status:
Not open for further replies.
  1. Razer Blade RZ09-0165 Wont Boot, Cant access BIOS.

    Hi, was hoping someone had come across something similar or can offer advice.

    I have a friends Razer Blade RZ09-0165,
    • It powers on
    • Lights up on keyboard
    • Razer logo comes on screen with 3 boot options -
    • Press F12 For Boot Menu / Press F1/Del for BIOS Setup / PressF9 for Recovery Menu
    When selecting any of the options nothing happens, the screen goes black but stays lit and the system stays powered on but nothing else.
    When pressing DEL however, the system just shuts off altogether.

    I've tried disconnecting the battery and discharging any charge.
    - After doing so the screen wouldn't even power on, the keyboard lit and it seemed to be booting but the screen was not backlit and stayed off - after about 30 - 60 mins I tried again and it started working again, well, it started doing the same as before.

    I obviously can't re-seat any RAM which I would usually try.
    I disconnected what I think was the CMOS battery although I usually deal with desktops but I assume it was.

    I have also tried plugging in a USB Keyboard for the same results
    I have plugged in an external disc drive to see if it would force a boot from disc but no luck.

    Any ideas would be much apprieciated,
    If you need any more information please let me know, I have tried to get as much as possible before posting.

    Thanks in advance.
     
  2. Razer.Caziel

    Razer.Caziel I am the Lightbringer Staff Member

    @coolWindsorTanportal149 This is a tough one. What I would highly recommend is to send it in for repairs if not just for diagnostics. Do send me a PM how you want to proceed so I can make the arrangements.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >