Razer Kiyo Suddenly Not Recognized

Discussion in 'Razer Support' started by xPancakethief, Oct 22, 2018.

Thread Status:
Not open for further replies.
  1. xPancakethief

    xPancakethief New Member

    Hello guys!

    So this happened - everything was fine and the sun was shining. Razer Kiyo cam was working like a charm - 720p = 60fps / 1080p = 30fps.

    I unplugged the USB cables from my PC for a few mins, the replugged them. Every other piece of equipment I have doesn't have a problem with being unplugged and put back in, but the Kiyo suddenly started acting strange.

    Under the device manager/camera it comes up as Razer Kiyo Camera, but in OBS, Discord, Skype - every other software that recognizes cameras is comes up as USB VIDEO DEVICE (where it was clearly Razer Kiyo everywhere, before I unplugged the USB cable).

    Now then, the image it gives is horrible, light is off, FPS is reduced and I cannot change it - it's like having a 10$ generic webcam.

    I tried reinstalling Razer Synapse, Removed/Uninstalled the "Camera Driver" under device manager, unplugged/plugged, restarted PC, updated FIRMWARE ON THE KIYO aaaand .... NOTHING. It still recognizes it as a generic webcame being named Razer Kiyo.


    ***I had the new Razer Synapse (beta) installed before that and the device appeared there - I could tweak settings and whatnot, not it shows up blank - it recognizes that a Kiyo camera is connected but the settings and everything window in the synapse is BLANK


    Please help me out here, I've been dangling for hours on this.
     
  2. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Hi there, @xPancakethief! I sent you a PM to further troubleshoot your issue. Please check your Inbox.
     
  3. xPancakethief

    xPancakethief New Member

    Update:

    Unfortunately the suggestions of a fresh install (delete .reg files and such) did not work. I tried to camera on a different PC with a freshly installed Synapse but alas - I didn't work.

    I contacted support and after a series of troubleshooting events, they deemed the product malfunctioning and advised me to contact my retailer to get it replaced.

    When the new one comes in, hopefully everything will be fine!

    Thank you for your time!
     
  4. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    You're welcome, @xPancakethief! Feel free to update us anytime if there's any issue you encounter.
     
  5. xPancakethief

    xPancakethief New Member

    UPDATE
    @Razer.BlueWanderer
    :

    I had a brand new Kiyo, shipped to be, since the previous one was deemed malfuncioning.

    This time it didn't take a couple of days for the quality to degrade - it was bad right from the connection.



    I am clueless as to what may be causing this. Changing resolution from 720p to 1080p , changing output FPS from default to highest and vise versa - does NOT change anything.

    I followed the steps you PMed me, uninstalled the Synapse Software, deleted the hidden folders, the REG files, reinstalled a fresh one - nothing.

    Tomorrow morning I will try a fresh OS install, as a last line of defense, but I'm not having any hopes that it will fix anything.


    *** I've attached an image of what Synapse is showing under Broadcaster
     

    Attached Files:

  6. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Got it. Let's continue through PM. I sent you a message. Please check your Inbox.
     
  7. Panndita_Icestars

    Panndita_Icestars New Member

    I have same problem like you, sometimes it lits the camera and get on all the time but without working or, synapse didn't recognize it, what have you done?
     
  8. _Major_Tom_

    _Major_Tom_ New Member

    I am having the EXACT same issue displayed in the attached image above - nothing shows up where the Kiyo should show up. In OBS I am able to see video, but this Synapse issue makes me very concerned.

    I just got this webcam 3 days ago - please help me so I don't have to return it...

    _Major_Tom_
     
  9. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Hi, all!

    Please send me a PM together with the Serial Number and Product Number of your Razer Kiyo. It would be best also if you can provide us some screenshots of your issue. Let's start there.
     
  10. _Major_Tom_

    _Major_Tom_ New Member

    Ok - new Razer Insider user here - where is your e-mail address for PM so I can send you the s/n?
    As far as screen shots, see attached:

    synapse-dashboard.jpg synapse-settings.jpg
     
  11. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Thanks for the update. I sent you a PM for us to continue troubleshooting. Please check your Inbox.
     
  12. Hi ! I have the exact same problem. I ve just received my Kiyo westerday and the camera worked for like 30minutes and suddenly stopped. The microphone seems to work but i have no image (like _Major_Tom_'s screenshots).
    Can you help me about that ?
     
  13. Razer.FatKidWanderer

    Razer.FatKidWanderer Just wandering around...

    Have you tried plugging it to another computer to isolate the issue? Have you also tried different applications and see if the camera does work?
     
  14. Yeah i tried it to another computer (Windows 10 too) and tried with 3 differents applications. The camera was still recognized. I also tried to update all the drivers (usb, razer and kiyo) and redownload windows 10 but still not fix.
     
  15. bcterry

    bcterry New Member

    I am having the same issues, Kiyo Settings missing from Synapse 3. Cam is completely underexposed when comes on automatically in Google Meet
     

    Attached Files:

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >