Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer taipan faulty cursor.

Discussion in 'Razer Support' started by nayef-mohy, Mar 23, 2018.

Thread Status:
Not open for further replies.
  1. nayef-mohy

    nayef-mohy New Member

    Hi everyone.

    A problem just appeared on my razer taipan, when ever i'm moving the cursor straightly to X or Y direction it

    just shakes (up and down) in a small radius never goes smooth straight and after many attempts, with software

    or cleaning the laser lens from the outside it just didn't work any ideas?
     
    orgildinio and Gabri110 like this.
  2. FiszPL

    FiszPL Well-Known Member

    What mousepad do you have? Laser sensors performing better on some hard pads.
     
    FirePenguin and Gabri110 like this.
  3. FirePenguin

    FirePenguin Well-Known Member

    Have you tried surface calibrating the mouse?

    *Moved to the Support section.
     
  4. nayef-mohy

    nayef-mohy New Member

    I'm using hard pads mats,books,papers & wooden tables. the mouse was working pretty fine on these types of surfaces until i stopped using for month .
     
  5. nayef-mohy

    nayef-mohy New Member

    The thing is when i connect my mouse into any of the usb ports, clicks left and right don't work laptop touch pad stops working for some weird reason it didn't fall from high places as it didn't face liquids just dust.

    Its a 4 year old mouse with +5k hours of working & gaming with it is it just the end?
     
  6. FirePenguin

    FirePenguin Well-Known Member

    Hmmm. Have you tried using it on another PC? Also, what version of Synapse are you using?

    Now that is a mouse that has a lot of years put in it. Would like to think it served you well </3.
     
  7. nayef-mohy

    nayef-mohy New Member

    Man u broke my heart XD.

    idk it just seems like its just a machine & doesn't break easily , im certain that theres a solution somewhere.
     
  8. FirePenguin

    FirePenguin Well-Known Member

    xD. Have you tried a clean reinstall of Synapse 2 on your PC with a fresh installer?
     
  9. nayef-mohy

    nayef-mohy New Member

    yes and I tried to calibrate too, maybe its just the end.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >