Ubuntu 17.10 & Blade Stealth (Late 2017) - Issues

Discussion in 'The Linux Corner' started by venturenexusLiver052, Dec 16, 2017.

Thread Status:
Not open for further replies.
  1. Hi all,

    I installed Ubuntu 17.10 with multi-boot Windows on my Stealth.

    There are three issues, I've got so far:

    A) Randomly freezing touchpad
    After some time, the touchpad seems to suddenly block / freeze without a reason.

    I tried it with evtest --grab /dev/input/event9 and it seems that the freeze looks like a "normal" "fingerUp":
    Code:
    Event: time 1513444029.948240, -------------- SYN_REPORT ------------
    Event: time 1513444029.955302, type 3 (EV_ABS), code 54 (ABS_MT_POSITION_Y), value 366
    Event: time 1513444029.955302, type 3 (EV_ABS), code 1 (ABS_Y), value 366
    Event: time 1513444029.955302, -------------- SYN_REPORT ------------
    Event: time 1513444029.969732, type 3 (EV_ABS), code 57 (ABS_MT_TRACKING_ID), value -1
    Event: time 1513444029.969732, type 1 (EV_KEY), code 330 (BTN_TOUCH), value 0
    Event: time 1513444029.969732, type 1 (EV_KEY), code 325 (BTN_TOOL_FINGER), value 0
    Event: time 1513444029.969732, -------------- SYN_REPORT ------------
    I'm using xserver-xorg-input-libinput
    Code:
    ⎡ Virtual core pointer                       id=2   [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
    ⎜   ↳ xwayland-pointer:13                         id=6   [slave  pointer  (2)]
    ⎜   ↳ xwayland-relative-pointer:13               id=7   [slave  pointer  (2)]
    ⎜   ↳ xwayland-touch:13                           id=9   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                       id=3   [master keyboard (2)]
        ↳ Virtual core XTEST keyboard                 id=5   [slave  keyboard (3)]
        ↳ xwayland-keyboard:13                       id=8   [slave  keyboard (3)]
    It seems that the cursor is sometimes "flickering" too when I try to make some tiny movements.

    B) A PCIe - Device is throwing a lot of errors
    Code:
    [ 2302.189383] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    [ 2302.189395] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=00e0(Transmitter ID)
    [ 2302.189402] pcieport 0000:00:1c.0:   device [8086:9d12] error status/mask=00001000/00002000
    [ 2302.189407] pcieport 0000:00:1c.0:    [12] Replay Timer Timeout  
    [ 2302.190222] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    [ 2302.190235] pcieport 0000:00:1c.0: PCIe Bus Error: severity=Corrected, type=Data Link Layer, id=00e0(Transmitter ID)
    [ 2302.190243] pcieport 0000:00:1c.0:   device [8086:9d12] error status/mask=00001000/00002000
    [ 2302.190247] pcieport 0000:00:1c.0:    [12] Replay Timer Timeout  
    [ 2302.190257] pcieport 0000:00:1c.0: AER: Corrected error received: id=00e0
    [ 2302.190272] pcieport 0000:00:1c.0: can't find device of ID00e0
    lspci:
    Code:
    00:00.0 Host bridge [0600]: Intel Corporation Device [8086:5914] (rev 08)
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:5917] (rev 07)
    00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
    00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
    00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21)
    00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21)
    00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
    00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port [8086:9d12] (rev f1)
    00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
    00:1d.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 [8086:9d18] (rev f1)
    00:1f.0 ISA bridge [0601]: Intel Corporation Device [8086:9d4e] (rev 21)
    00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
    00:1f.3 Audio device [0403]: Intel Corporation Device [8086:9d71] (rev 21)
    00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
    01:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    3b:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961 [144d:a804]
    C) Speakers are not working at all
    Bluetooth & headphone jack are booth working with good quality (tested with youtube)



    The most annoying issue is A) , because I cannot work properly with the touchpad :-( .

    I can send you a lot of more details, but I don't know which one, so please just ask for it ;-)

    OK, the speakers are now working (without any changes ^^)
     
    Last edited by a moderator: Jan 3, 2018
    Zeeraa likes this.
  2. therave39

    therave39 New Member

    Hey, I'm in a similar boat with the touchpad. I followed this guide to get everything set up: https://github.com/rolandguelle/razer-blade-stealth-linux

    What I've noticed is that there's a certain area of the touchpad (almost the exact center, slightly off to the left) that will register a "button up" event whenever I pass through it. This causes the motion to stop tracking, and if I happen to start in that area, it will immediately register a click and not move the cursor at all.

    Here's the libinput debug output when I put my finger down in the problematic area:
    Code:
    event9  - thumb state: THUMB_STATE_MAYBE → THUMB_STATE_NO
    event9  - button state: from BUTTON_STATE_NONE, event BUTTON_EVENT_IN_AREA to BUTTON_STATE_AREA
    event9  - button state: from BUTTON_STATE_AREA, event BUTTON_EVENT_UP to BUTTON_STATE_NONE
    It doesn't always have this behaviour though, as I'm writing this, it's working 100% fine, however in a few minutes it will start losing tracking again. I'm not entirely sure why, but hopefully this can help us find a resolution!
     
  3. I know what you mean!

    I believe that the touchpad works real better after a suspend. It's flickering 50% when I reboot and after a while just about 20% of the time

    I now returned from the suspend mode and now it works to 98% of the time

    Maybe it's better with the openrazor driver from https://github.com/openrazer/openrazer , but it would brick the secureboot, so I'm not using it yet.
     
  4. therave39

    therave39 New Member

    I tried some things last night and seemed to have some success:
    * Updated the kernel to 4.14.8
    * Updated libinput to 1.9.900 (had to build from source, see https://wayland.freedesktop.org/libinput/doc/latest/building_libinput.html)

    It's still a little weird, but it seems to be working more consistently. What I've still noticed:
    * The "deadzone" still exists sometimes (usually after resuming from suspend), however after time it seems to work
    * After resume, the area surrounding the "deadzone" will make the cursor vibrate when the finger is tracking in that area

    I have Openrazer installed, which has really only helped with giving me Chroma access for the keyboard. You can install the driver without issue, but as long as secure boot is enabled, the driver won't detect any devices. I just ended up disabling secureboot for my sweet spectrum wave.

    Good news my friend! It looks like the kernel version 4.15-rc6 has fixed the trackpad issues!

    Also, if you have any screen flickering issues, this guide fixed them all for me: https://github.com/hyphone/razer-stealth-late-2017-kblrefresh-linux/blob/master/README.md
     
    Last edited by a moderator: Jan 3, 2018
  5. Haa.. You're right. It seems like the trackpad is working now :)

    I also used the kernel parameters

    Thank you for your input! Now I'm really happy with my razer :)

    [Edit] Now it freezes again sometimes :-( .. Strange thing..
     
    Last edited: Jan 3, 2018
  6. geoPruneworld258

    geoPruneworld258 New Member

    hi all just finished setting up my new razer stealth on 17.10 after no luck with 16.04, i follow this guide https://github.com/rolandguelle/razer-blade-stealth-linux as well, and have some minor issue, but out of curiosity here, are this is normal for razer laptop not turn on the fan afte cpu heat hits 47 C, i try use tlp but cant get the fan speed. anybody having same issue ?
    thanks
     
  7. Asten__

    Asten__ Active Member

    Greetings!

    I own a RBS Stealth 2017 and had virtually no issues with Debian Stretch 9.2 (xcept slow network performance on wifi) - maybe because the kernel is newer?
     
  8. Lemoussu

    Lemoussu New Member

    Hi all, I received my RBS 13.3" 2017 a few days ago, and did a fresh install of ubuntu 17.10.

    @geoPruneworld258 : I had the same question. I wouldn't say issue because temperatures are stables. I believe that the fans work in a slow fashion, else my RBS wouldn't stay at 47-48°C, but as for now I have no real proof that the fans are working...
    I tried sensors-detect but the FAN RPM is not showing, this may be why you can't get the fan speed from tlp.

    @therave39 : Thanks for the link, my trackpad works better now, but still jitter from time to time.

    My biggest issue for now is the screen flickering... It's not an heavy flicker, but it's definitely annoying.
    It happens more often when watching a video, and goes crazy after the RBS tries to go idle without closing the lid.
    Maybe a power saving parameter...
    I did read somewhere on this forum that this issue is resolved on 1080 screen resolution, didn't have the chance to try it yet.
    Is there anyone having the same problem on an RBS 13.3" with i7 8th Gen ?
     
  9. kir13y

    kir13y New Member

    Did you guys ever fix the speaker issue? I had the same issue with mine. Are you dual booting Windows 10? If so, just load into the Windows side and shut it down (don't restart). Then power back up and go into Linux. It's a hack but it fixed it for me.
     
  10. Lemoussu

    Lemoussu New Member

    @retrocampOldRose752, still no fix on my side for the speaker issue.

    I'm also on a dual boot with windows 10 : windows 10 for gaming, ubuntu for working (I'm a developper).
    For now, Ubuntu 17.10 works flawlessly if I boot right into Ubuntu from a shutdown state : no audio issue, no screen flickering, trackpad does track well.
    But if I restart from windows to boot into Ubuntu, then I have every issues mentionned above. And if closing the lid does fix the audio, I still have a screen flick from time to time, and a crappy tracking trackpad.

    If you don't have to switch a lot between Ubuntu and Windows 10, I'd suggest that you always shutdown your computer when switching from Windows 10 to Ubuntu. Again, Ubuntu17.10 works flawlessly doing that way.

    I didn't experience any issue restarting from Ubuntu to boot into Windows10.
     
  11. technoFrostbite929

    technoFrostbite929 New Member


    So I updated to kernel version 4.15-rc7 and I am still getting the deadzone problem on my trackpad. I am going to try and build libinput from source and see if that helps.

    Ok so update here, it seems as though like someone else mentioned, if I shutdown my windows installation and then boot into ubuntu the touchpad works fine (not sure about the old kernel but it does on 4.15-rc7), but if i close the lid (set to hibernate) and then boot into ubuntu the trackpad has the deadzone. Super weird....
     
    Last edited by a moderator: Feb 1, 2018
  12. Lemoussu

    Lemoussu New Member

    Wrong driver loaded after waking up ? I didn't check if there was more than one driver associated with the trackpad, or if the material is detected differently after a wake up process. I'll have to check later.
     
  13. rmasclef

    rmasclef New Member

    Hi there ! any updates on the jumping pointer part ?
     
  14. Lemoussu

    Lemoussu New Member

    Hi ! I did some apt upgrade lately, and I find the pointer a little less jittery...
    Anyone else ?
     
  15. rmasclef

    rmasclef New Member

    Not for me :slightly_sad:

    I've got the latest stable kernel version (4.15.5 by the time I'm typing those words ^^).

    I've detected that the pointer seems to bug more when using intel gpu ...
    I'm also using https://github.com/iberianpig/fusuma in order to have a way better multitouch :)

    when I deactivate fusuma, the cursor seems to be more "compliant" ... but I can't use the trackpad without multitouch gesture :/
     
  16. Lemoussu

    Lemoussu New Member

    I didn't know Fusuma ! That's interesting !

    I still use the 4.13 kernel, the one bundled with 17.10, and I tried again yesterday to work with the trackpad. I really think that something is on the right path.

    Still not a great experience tho...
     
  17. rmasclef

    rmasclef New Member

    Yeah fusuma is really great, it really enables the multitouch part of a touchpad ;)

    But, sadly, it seems that fusuma makes the problem even more annoying ...

    I have no idea how to fix that and it's killing me for a 2k€ laptop !!
     
  18. 3dpro

    3dpro New Member

    Hi, just got the laptop and i've also experienced the touchpad shaking too. I'm using Antergos with 4.16 mainline kernel and it seems to still having the problem.

    I also saw someone open the bug for libinput here: https://bugs.freedesktop.org/show_bug.cgi?id=105409
     
    Last edited: Mar 12, 2018
  19. therave39

    therave39 New Member

    That's me!

    The libinput dev made a pull request on the systemd repo with a fix for the shaking: https://github.com/systemd/systemd/pull/8436

    In the meantime, you can fix it making some hwdb changes. You can find instructions here: https://github.com/whot/systemd/blob/13fa5b53274483105e933de1aaf4d1f4f2c1bd5c/hwdb/60-evdev.hwdb

    Here's my 61-evdev-local.hwdb file:
    Code:
    # Razer Blade Stealth
    evdev:name:1A586753:00 06CB:8323 Touchpad:dmi:*svnRazer:pnBladeStealth:*
     EVDEV_ABS_00=0:1220:12:8
     EVDEV_ABS_01=0:721:11:8
     EVDEV_ABS_35=0:1220:12:8
     EVDEV_ABS_36=0:721:11:8
    
     
  20. 3dpro

    3dpro New Member

    thanks for the help! I'm still having a problem with updating evdev config though.

    I have build and install libinput from master branch via AUR, put hwdb file at /etc/udev/hwdb.d/61-evdev-local.hwdb and ran systemd-hwdb update. It seems that udev still not registered the update config yet. here's my output from udevinfo:

    Code:
    # udevadm info /sys/class/input/event14
    P: /devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-8/i2c-1A586757:00/0018:06CB:8323.000A/input/input20/event14
    N: input/event14
    S: input/by-path/pci-0000:00:15.1-platform-i2c_designware.1-event-mouse
    E: DEVLINKS=/dev/input/by-path/pci-0000:00:15.1-platform-i2c_designware.1-event-mouse
    E: DEVNAME=/dev/input/event14
    E: DEVPATH=/devices/pci0000:00/0000:00:15.1/i2c_designware.1/i2c-8/i2c-1A586757:00/0018:06CB:8323.000A/input/input20/event14
    E: ID_INPUT=1
    E: ID_INPUT_HEIGHT_MM=60
    E: ID_INPUT_TOUCHPAD=1
    E: ID_INPUT_WIDTH_MM=101
    E: ID_PATH=pci-0000:00:15.1-platform-i2c_designware.1
    E: ID_PATH_TAG=pci-0000_00_15_1-platform-i2c_designware_1
    E: ID_SERIAL=noserial
    E: LIBINPUT_DEVICE_GROUP=18/6cb/8323:i2c-1A586757:00
    E: MAJOR=13
    E: MINOR=78
    E: SUBSYSTEM=input
    E: USEC_INITIALIZED=3318464
    I don't see any properties from LIBINPUT_FUZZ as the libinput dev said.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >