3 months owning a Razer Blade Stealth Review

Discussion in 'Systems' started by Nektai, May 11, 2016.

Tags:
Thread Status:
Not open for further replies.
  1. MarcusChai

    MarcusChai Active Member

    Is ok, they offer me to change a new one
     
  2. JETcoolCoolBlack681

    JETcoolCoolBlack681 Active Member

    For the case if the new one suffers from that as well. :)
     
  3. MarcusChai

    MarcusChai Active Member

    nope new one came in perfect condition haha, just that when i shutdown it was 100% and when i on again like 10 hours after it become 35%
     
  4. TrueLightbringer

    TrueLightbringer Active Member

    You sure it was fully shut down and not put to sleep or hibernation or some weird mix like that? The Stealth noms battery when it's just sleeping, I'll tell you that. Compared to losing about 2% or so after shutting it down for the whole night, I have now the habit of shutting it down if I'm not going to use it in the next 30 minutes lol.
     
  5. holl0304

    holl0304 New Member

    I just received mine today. The Green LED Charge light on front panel is not working. The biggest issue is the headphone jack only works if I hold pressure on the jack. The moment I take pressure off the headphones stop working and it goes right back to speaker volume. I am going to create a support case for both issues now. Other than that the system is great so far, I just hope I don't have to ship it back.

    Edit: I thought I had an issue with the LED and the headphone jack but apparently I needed to do my research before posting. The green LED does not come on when charging, LED is working fine. I tested it by putting the system in Sleep mode and saw it pulsing White.

    Also, I talked to support and they said the connection for headphone jack is snug. It felt like I was breaking the laptop with the amount of pressure I had to put on before the jack snapped into place. I am sure it will loosen up over time. It is working great, I guess I was just being a little too careful with my pretty new toy!
     
    Last edited: May 13, 2016
  6. jaseow

    jaseow Active Member

    Haha I had the same problem. I turned off my RBS and left it to charge and the LED light didnt show anything! I thought I had a problem with the charger not working like some people have posted. Then I read their FAQ and their LED lighting patterns are quite different from other laptops.

    I turned it on again just to check it was charging and its all good. haha
     
  7. MarcusChai

    MarcusChai Active Member

    Yes shut down from the start menu let me have a few test
     
  8. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    I have my stealth set to hibernate after 3 hours of sleep- but don't think I see any noticeable drain from sleeping. It does wake up very quickly, which is a nice change from the XPS series which wake quite slowly.
     
  9. MarcusChai

    MarcusChai Active Member

    I think the green led will only show once you connected to Razer core
     
  10. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Nope, it's for showing that the laptop is on w/ screen off, or asleep. Only those two functions.
     
  11. MarcusChai

    MarcusChai Active Member

    just did a google search and found out intel management engine interface will cause the battery drain. did you uncheck "allow the computer to turn off this device to save power" in intel management engine interface properties ?
     
  12. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Nope. Don't even know where that is in the device manager
     
  13. MarcusChai

    MarcusChai Active Member

    Oh it's in device manager > system devices. Please have a check :)
     
  14. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    Yup, it is checked
     
  15. MarcusChai

    MarcusChai Active Member

    hihi thanks, my RBS now become normal, no battery drain now after i turned off :wink_:
     
  16. PastelGraywatchsharp937

    PastelGraywatchsharp937 Active Member

    So you're saying I should turn off IME's ability to enter power-saving mode?

     
  17. MarcusChai

    MarcusChai Active Member

    I think there is a bug on my system I just reinstall it and turn it off and on now my system no more battery drain
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >