Atheris wont re-connect!

Discussion in 'Razer Support' started by buzzPatriarchguide657, Jun 15, 2018.

Thread Status:
Not open for further replies.
  1. madcapacity

    madcapacity New Member

    Dammit, I was hoping there'd be a solution. Feels bad having a product that doesn't work when both of them are Razer.
  2. Yep, the only solution for me as of now, is to not use the mouse.....heh
    Write it off as a loss and not by Razer anymore.
  3. gelangenie

    gelangenie New Member

    Hi Madcapacity, geoLightGreenLife340,
    I'm talking to razer support through Razer Insider Conversation and through email. So far, they've just requested me to install the latest synapse 3, and share logs with their log tool. I'll see this through and update here if I get some concrete.

    In the meantime, i've switched to the USB dongle for gaming, or running the "troubleshoot bluetooth" workaround i detailed previously.

    Some hope though from a reddit post: someone got a firmware update that included a fix ( I mentioned this with Razer support explicitly and I hope this can get things moving.
  4. madcapacity

    madcapacity New Member

    Thanks a lot - I'll be watching this thread intently! I saw that there was a firmware fix but wasn't able to get it out of Razer support. I'm not sure if it actually exists or not.
  5. Thanks for the info on the firmware update. I am also working with Razer support as well. Got them my logs as well just no replies from them yet. I emailing them now asking about this firmware update.
  6. gelangenie

    gelangenie New Member

    Hi everyoone,

    Razer support shared these instructions for the firmware which fixed the issue

    Please follow the steps below to update the firmware of the Atheris :

    1. Exit Synapse through the task manager.
    2. Download this firmware update at :
    3. Unplug the device.
    4. Re-plug the device, preferably to a different USB port.
    5. Install the firmware update; execute the installer as an administrator.

    If issue still persist, we will need to endorse your case to our Peripherals Team for further assistance.



    Note that my current system has
    - Intel bluetooth driver version
    - razer synapse version
    - bluetooth driver Power Management setting "Allow the computer to turn-off this device to save power" set to enabled

    After going through the atheris firmware update steps (paused for a bit at the step that told me to search for DfuMadison among the bluetooth devices) and rebooting, the atheris mouse on bluetooth-mode now:
    - automatically connects on reboot
    - will show repeating blue light while windows boots, then blue light shifts to steady around the same time win10 login prompt is available

    I rebooted a few times to confirm the fix, and realized that my blade 15 win10 turns off laptop bluetooth receiver when in battery mode.
    After plugging in my blade 15 and tried to confirming the fix again through reboots, I couldn't replicate the issue.

    Hope this fix sticks, and that this helps you guys, too.
    And of course, big thanks to Razer support for the action.
  7. Thanks for that, but no joy. apparently mine already has that firmware version. ;/
  8. Giolon

    Giolon New Member

    Same for me. I already have the latest firmware on my Atheris (1.0.3). As said earlier in the thread, Intel BT drivers is unusable for me as my machine experiences many issues fixed in later updates (Bluetooth device disappears from windows, Hands-Free Profile audio session causes mouse to lag, Hands-Free Profile experiences poor audio, Bluetooth device disappears from windows after waking from sleep, etc.) It'd be nice if Razer could talk to Intel about what's causing the re-connection problem in driver and newer.
  9. gelangenie

    gelangenie New Member

    Sorry to hear that. Hopefully the logs will help Razer support troubleshoot for you.

    It might help, but I did learn that
    - the issue may be laptop power setting related, since my blade 15 battery mode turns-off Bluetooth receiver on boot
    -- this can be fixed in the advanced section of windows settings for pwer management
    - and, going to the windows notification center, and clicking "connect" nudges the Bluetooth receiver / atheris pairing as a workaround

    Still, not a clear fix, and I can imagine how so many things can go wrong when setting devices up.
    If you guys have questions about my setup in order to compare with yours, feel free to ask.
  10. Kliffside

    Kliffside New Member

    Thanks for posting the driver, but unfortunately the Atheris mouse still doesn't automatically reconnect back to the laptop. I'm using a Gigabyte Aero 15 by the way. My Intel Bluetooth Driver has been updated to, the DfuMadison that was installed with the Razer Atheris update does automatically reconnect, but the mouse still does not work.
    At the moment, the only workaround is to run the Bluetooth search in the Settings>Add Bluetooth or other device. Funny thing is that I do not need to remove the mouse or click anything else, the mouse will connect once I run the search.
  11. gelangenie

    gelangenie New Member

    Hi Kliffside,
    How about rolling back to the Intel Bluetooth driver?

    Also, have you tried setting the Bluetooth power management "allow computer to turn off this device to save power" to enabled?
  12. laceyboy

    laceyboy New Member

    I was on a different thread and got supported with other Razer tech.
    My Atheris' firmware was 1.01 and after I updated it to 1.03, it fixed re-connection issue.
  13. So I am still working with support going in circles it seems. Same questions new agents/tier. Getting no where fast, this is like watching paint dry. Anyhow, the 1.03 firmware update is not suppose to fix the reconnection issue according to support, actually, the reconnection issue is not a known issue according to them LMAO. Really?!

    "Thank you for contacting Razer Peripherals Support. We are glad to assist you.

    We understand that you have been waiting for a feedback regarding your complaint with your Atheris mouse, it will not reconnect whenever the Surface Book 2 or the computer is restarted. We are aware, too, that you have the same issue with the replacement mouse from Amazon.

    It is not a known issue of the mouse. We have a firmware for the said mouse however, it is not a fix for the said concern. Hence, please refrain from updating the firmware.

    What we can do to further assist you is to escalate this to our Tier 2 Team to further check for a possible solution regarding this issue. We would like to know the following information prior to the escalation of this case.

    1. Was there a time that the mouse (whether it is a replacement or the original mouse) reconnects when the Surface Book 2 was restarted?

    2. A PDF copy of the proof of purchase of the original mouse.

    Have a great day ahead and thank you for supporting Razer! "
  14. laceyboy

    laceyboy New Member

    @geoLightGreenlife340, are you using Surface Book?
    They also asked about Surface Book but I have RB Stealth.
    However, as I said above, new firmware fixed the problem for me.
    Have you tried to uninstall and re-install everything?
  15. yes I have, been through 2 of the mice now. Tried on multiple computers/laptops. Even reinstalled Windows. I am an IT professional, so I certainly know my way around a bit.
  16. laceyboy

    laceyboy New Member

    I might get lucky to have it fixed since I don't know anything about computer.
    I just follow the instructions.
    Wish you luck
  17. DJRiful

    DJRiful New Member

    Hey guys,

    After months of struggles and I was stuck using my Wireless dongle. I finally give another try to fix it; I did download the latest Intel Bluetooth Driver No lucks.

    I remember 10 years ago I had a bluetooth speaker and a crappy motorola phone with bluetooth capability, Windows often confused with the device profile. It set my phone as Mouse mode or my speaker as phone mode and each of those devices shows as connected but doesn't work for crap.

    2018 today, this is the exact same situation. I managed to fix it completely even running the latest driver. What I did was uninstall all Razer software and driver on every trace level. Second part is the most important part you need to do.

    Right click on the Start button and click Device Manager. At the top menu click View then Show Hidden Devices. Please disconnect your Razer Atheris mouse, turn off the bluetooth and remove the dongle. Use another mouse for now or your laptop trackpad.

    Open every single categories and look for Razer Atheris and if you see one; right click on it and Uninstall Device.

    This is what I found out my problem, my Razer Atheris was shown as Speakers, Keyboard and Mobile Phones... Windows 10 set my mouse into a wrong profile. That is why it wasn't working. It should only shows under Mice and other pointing devices category.

    Last resource downgrade to Intel Bluetooth: 20.30
    Last edited: Sep 27, 2018
  18. Giolon

    Giolon New Member

    Ok, it's early days, but on Bluetooth version 20.70.04 and the new Windows 10 October 2018 Update ver 1809, my Atheris appears to be connecting and re-connecting properly via Bluetooth, even after rebooting or sleeping my machine, or turning the Atheris off or on. I'll give it a few more days before declaring the problem solved, but the early indications are promising.
  19. Kliffside

    Kliffside New Member

    Hi, I am glad that the Bluetooth issue has been finally fixed in the recent updates. The mouse automatically reconnects when switching to Bluetooth mode and I can modify its settings in the Razer Synapse. But now a new issue has surfaced in the Synapse, when I switch back to the 2.4Ghz mode from Bluetooth mode, it seems to lock the DPI for the mouse as the DPI does not change not matter what DPI value I set in the Razer Synapse.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >