Better, Faster, Brighter | The New Razer Blade

Discussion in 'Systems' started by technokat, Mar 15, 2016.

Thread Status:
Not open for further replies.
  1. igonzales20

    igonzales20 Member

    One of the most A E S T H E T I C laptops.
     
  2. This sounds exactly like what I'm experiencing- have tried multiple TB3-to-ethernet adapters (multiple brands) and the port appears dead as a doornail. Curious- I'm guessing you bought your Blade from the MS store? Did you happen to get it circa mid-May when they were first available? I ordered 5/13 and am wondering if this may have been a bad batch...
     
  3. merrinator

    merrinator New Member

    I'm experiencing an issue with the "time remaining" for battery life that is calculated in Windows 10. Whenever I charge the laptop to full (lid closed), and then disconnect to use the laptop, the time remaining shows "Calculating..." forever.

    Only solution is to plug the laptop in and then it will properly calculate time to full charge. I can then disconnect again and it will calculate the remaining time. There is a caveat to this workaround - the charger shows "Plugged in, not charging" between 95-100% so you have to drain the battery a bit. I'm assuming this is a feature to prevent overcharging?

    If anyone has experience with this issue, please let me know. It's rather annoying I have to unplug, wait until I reach 95%, plug back in, calculate charge to full, unplug, just to calculate battery time remaining.

    Edit: Got it a week ago at the Microsoft Store
     
  4. Derek712

    Derek712 Active Member

    Same here. Never got it fixed either. Did you do a fresh install by any chance?
     
  5. TheGurgeMan7

    TheGurgeMan7 Well-Known Member

    Thats just windows 10 being funky
     
  6. merrinator

    merrinator New Member

    Nope. Heard something about needing to get a restore stick? I don't think a new install will change anything as this is happening right out of the box. I've drained the battery to ~3% a few times and charged it back up to 100%. Nothing has made the issue go away. Driver issue maybe?
     
  7. Derek712

    Derek712 Active Member

    I was only asking because I did a fresh install and always assumed that was the cause. I'm going to assume this is going to be an issue forever like the hp spectre.
     
  8. merrinator

    merrinator New Member

    It's supposed to be the Macbook killer and with a $2k price tag, I'm disappointed my laptop can't tell me when it's gonna die.

    I've encountered a new issue with my Blade when using a 2012 Razer Naga external mouse. Upon plugging in the mouse, it updates my mouse registry speed key to 0, as well as mouse threshold 1 and mouse threshold 2. This causes my trackpad to be INSANELY slow, like 5 swipes to get across the screen. I believe this is the infamous "slow trackpad" issue that plagues the Blade line.

    Luckily, I had a second user account on the machine. I was able to log in with a correctly working touchpad. Looked int he registry for these three keys and found 1, 6, 10 respectively. Went back, updated registry to these, restarted and my touchpad was working properly again.

    But, every time I plug in my Naga to game, it resets my registry keys all over again. Rinse and repeat until you're banging your head on the desk...
     
    Last edited by a moderator: Jul 2, 2016
  9. TheEdge003

    TheEdge003 New Member

    I had the same "calculating" issue. Support worked with me and they were great (on this issue, as well as a bad power adapter right out of the box - Thank you Sean, Dan, and others) and I ended up having to RMA mine. The new unit seems to be working properly so far. I will keep everyone posted as it has only been a couple of days
     
  10. Spenceryork1992

    Spenceryork1992 New Member

    I got the new blade and I'm noticing when holding a key down, a slight lift while leaving the key pressed stops input. Like if I'm in a game running, my character will stop if I'm not pushing the key hard enough. Anyone got this problem with their keyboard? It's so annoying.
     
  11. holja

    holja Member


    Same here. I thought it was just me. The W key is the most notable because I use it the most in games. It's not really a ghosting issue but in my case I do have to fully depress the key before being able to reingage the action (meaning I can't just push harder on W to start running again).
     
  12. Blockmonster57

    Blockmonster57 Active Member

    Contact Support.
     
  13. TheGurgeMan7

    TheGurgeMan7 Well-Known Member

    It not really a support problem, its related to the blade, as mine does it as well, it need to be really depressed to trigger it. Its fine while typing, but annoying while gaming. Thats why I use an external keyboard.
     
  14. holja

    holja Member

    I'm also not sure it bothers me to the point of contacting support. Maybe if it gets worse. I also have the battery 'calculating time remaining' issue but again, doesn't bother me too much. I just installed BatteryBar. If it gets worse maybe I'll have them take a peek.
     
  15. 216950480

    216950480 Member

    Yes, I can finally scrap my crappy alienware 13 and step up the gaming ladder w/ one of these bad-boys.
     
  16. torrented

    torrented New Member

    Its due to the shallow key travel... use an external keyboard
     
  17. Mehcko

    Mehcko Member

    so thin, so beautiful
     
  18. PaksuBerttaRazer

    PaksuBerttaRazer New Member

    best laptop i ever seen
     
  19. Spenceryork1992

    Spenceryork1992 New Member

    I was mainly referring to the amount of pressure it takes to keep the key registering input while pressed fully but I'm noticing that specific "w" key issue more and more which seems like a separate problem. It's incredibly frustrating and I hope there's a driver update/fix. I was just playing some l4d2 and got stuck in hordes multiple times because my character would just stop running.
     
  20. vag26

    vag26 New Member

    Does anynone have any idea when Razer Blade 2016 in Singapore will be restocked? I was about to add to cart and pay for it when it just turned from (add to cart) to (notify me) fml....
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >