Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

DeathAdder Synape product registration

Discussion in 'Razer Synapse' started by Narinas, Dec 6, 2017.

Thread Status:
Not open for further replies.
  1. Narinas

    Narinas New Member

    Hello i today (06.12.2017) purchase DeathAdder Chroma in store and dowloand synape becoause i want to setup my mouse when i fill everything product num. etc.. it saying its wrong but its right so i dont know what to do now...
    JackyJChan and catpawerr like this.
  2. JustJozef

    JustJozef Active Member

    Which version of Synapse are you using? If I remember right, I thought like mouse, keyboard and stuff automatically registered or linked to your account.

    In v2 you can click the little arrow by your username in the upper left hand corner, Pick warranty status and see if it's there.

    Other than that I guess I'd double check and if you're entering everything right and it's still not recognizing the product # you'll have to contact support, unfortunately
    JackyJChan, catpawerr and Hucast like this.
  3. CiannPT

    CiannPT Active Member

    Try to do it again tomorrow and if you are sure you are not making a mistake with the info try to contact razer suport here.
    JackyJChan and catpawerr like this.
  4. Narinas

    Narinas New Member

    In warranty status is nothing.. I try put mouse to every USB and reinstall Synape v2 and still not showing in..
    deKINNNn, JackyJChan and catpawerr like this.
  5. .Surf.

    .Surf. Well-Known Member VANGUARD

    You didn't enter the right serial number, it also happened to me twice. Try and find the correct one since there are more than one on the back of your mouse.
    deKINNNn and JackyJChan like this.
  6. Narinas

    Narinas New Member

    I tryed every numbers on mouse and nothing..
    deKINNNn likes this.
  7. JustJozef

    JustJozef Active Member

    Well I just tried adding a device so I could refresh my memory on what numbers it asks for. looks like first it wants the product number, which on my DeathAdder Elite is the 3rd line. The one right under "gaming mouse" then the serial number which is below the barcode in the grey strip. I would assume it wants the letters before the numbers too, but if it doesn't work, try without.

    All else fails, you'll have to contact support using the link CiannPT provided.
Thread Status:
Not open for further replies.
Sign In with Razer ID >

Don't have a Razer ID yet?
Get Razer ID >