Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. illathon

    illathon New Member

    It works for me in 14.04 no problem. I installed the wily kernel and got the track pad working. Just read my previous post on how to do that.
     
  2. Hmizer

    Hmizer New Member

    Thanks Goddard. I'm going to try 16.04 LTS tomorrow and if suspend is still broken I'll revert to trying 14.04. I did try a live USB of 14.04 and it had issues with suspend as I recall.
     
  3. illathon

    illathon New Member

    If suspension isn't working for you guys did you install using a swap partition? It should be equal to the amount of ram you have.
     
  4. urbanBlacklab029

    urbanBlacklab029 New Member

    @Goddard I don't have anything listed as swap in df -lh. Did you have to manually create that? I've done it on other OS's before but I assumed it was automatic on something like ubuntu.
     
  5. illathon

    illathon New Member

    I think it depends on how you install.
     
  6. 9377519279

    9377519279 Active Member

    If there's one great thing that came out of Steam OS, it is Nvidia driver support for Linux. Trying to hodge podge drivers before official support was such a pain. Good luck with Linux I would be interested to see how the core would work on something like Steam OS since it seems like the core is very driver dependent on per manufacturer of the chipset and i'm not sure those drivers have Linux counterparts.
     
    Brastic likes this.
  7. illathon

    illathon New Member

    Linux already had Nvidia driver support before SteamOS. In fact a lot of people use Linux for scientific computing which requires GPUs. Nvidia is invested in Linux with its digits platform and also embedded devices such as the TX1.

    It has been extremely simple to easy drivers for over 7 years now. AMD's open source driver is now also a recommended driver for a triple AAA game that is being released for Linux, Tomb Raider.

    I to am very interested in support for the Core. Not sure what chipset they are using for the port, but Dell added Thunderbolt 3/USB-C support already and in the past with USB 3 we have had working eGPUs so it should work eventually. I think the only real limitation in that regard is using Wayland/Mir instead of X11 which would require special support from driver manufacturers like AMD and Nvidia.
     
  8. 9377519279

    9377519279 Active Member

    Yea you could get it work, but it was def not as easy as it is now.
     
  9. illathon

    illathon New Member

    Was easy for me and I have been using it that long. Since 9.10 we have had jockey which manages driver installs. If you tried to install drivers manually it was more difficult if that is what you tried to do.
     
  10. I have 15.10 on a 2014 14" Blade. I have everything working that I can see so far, except I cannot get it to resume after suspending. It seems like it never actually suspends either because it is still very warm after being suspended for awhile. Any ideas?
     
  11. urbanBlacklab029

    urbanBlacklab029 New Member

    @CAPcadetJC I've verified the swap didn't install properly using the default installation. I haven't had time to reinstall and test it but a few post back I posted the commands on how to check and activate the swap if it isn't installed. At the moment I have a different distro installed but I'll probably test it tonight.
     
  12. RScrub

    RScrub Active Member

    Damn I thought that it was Linus Tech Tips talking about the new Razer Blade
     
  13. After upgrading to 16.04 mine is running way more stable now. Still can't suspend though :frown_:
     
  14. Tr1ckyPlayz

    Tr1ckyPlayz Member

    It worked for my friend
     
  15. Hmizer

    Hmizer New Member

    So I upgraded to 16.04 LTS and still no suspend. When I go to suspend the screen goes black but the LED stays green (not white) and the machine doesn't wind down (fans run, logo on back of screen still on etc.). This is with any driver (open/nvidia).

    I did a default install which shows a swap partition of 15.92 GB while info shows RAM of 15.6 GB (why not 16?)

    any help appreciated...getting tired of window 10 as my daily driver owing to no suspend. Thinking of selling this and getting a System76.
     

  16. Those are the exact same results I am getting. Though I don't know how to look at the size of my swap partition to see if its the same as yours.


    EDIT: My swap partition is 8.5 GB, so I assume that's not good if you have one that's 15.6. Though I have mine installed on a second SSD that is 120GB total, so maybe that affected the default size?

    df -lh

    Filesystem Size Used Avail Use% Mounted on
    udev 3.9G 0 3.9G 0% /dev
    tmpfs 791M 9.7M 782M 2% /run
    /dev/sdb2 102G 8.6G 88G 9% /
    tmpfs 3.9G 52M 3.9G 2% /dev/shm
    tmpfs 5.0M 4.0K 5.0M 1% /run/lock
    tmpfs 3.9G 0 3.9G 0% /sys/fs/cgroup
    /dev/sda2 96M 32M 65M 34% /boot/efi
    tmpfs 791M 48K 791M 1% /run/user/1000


    EDIT 2:
    $ cat /proc/swaps gives

    Filename Type Size Used Priority
    /dev/sdb3 partition 8310780 0 -1
     
    Last edited: Apr 24, 2016
  17. carlrice

    carlrice New Member

    For those experiencing freezes (and hot machine with fans blasting) on suspend, downgrade to Kernel 4.2 or upgrade to Kernel 4.6 and you'll be back to your same old 30 second suspend loop :)
     
  18. illathon

    illathon New Member

    I will have to look into this and see if I can find a fix.
     
  19. Hmizer

    Hmizer New Member

    I just used gparted to look at the size of my swap partition.

    Is there a fix for the 30 second suspend loop?
    Is there ANY way to fix suspend in Ubuntu?
    How about any other distro?

    I hate W10 so much I'm constantly shutting down but would love to have suspend.
     
  20. illathon

    illathon New Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >