Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. Hmizer

    Hmizer New Member

    Goddard, thanks. I recall you had to configure quite a number of things post install, no? Something about a black screen on first boot?

    And you're saying you have no issues with suspend?

    I ran the 14.04 live USB and found it wouldn't suspend so I assumed a full install would have the same issue.
     
  2. funbestCoral612

    funbestCoral612 New Member

    I have been running this for over a year now so can't remember all the little tweaks I did. I just know that all the major functions work in 14.04 with the wily kernel.

    Unless my model is some how different then yours it should work fine. Not sure if they came out with multiple revisions of the 2015 model.

    I am also using the CUDA installer from Nvidia, but that is because I needed CUDA. Not sure if that is required, but you can look at my previous posts in this thread about it if you run into problems.

    So far I can switch between intel/nvidia. I can suspend. The trackpad works completely. All function keys work and I get battery life comparable to Windows.

    The only thing I have had an issue with now is using a bluetooth mouse with a bluetooth speaker at the same time, but I think that is a software bug rather then not reading hardware correctly. I haven't figured it out as I moved on to other things..
     
  3. urbanBlacklab029

    urbanBlacklab029 New Member

    4.6rc5 kernel on 16.04 suspend works but loops on the lid close status. When opened back up it continues to report the lid as closed.

    I've set the lid to ignore instead of suspend, and use the power button to suspend. Still ends up looping.
     
  4. carlrice

    carlrice New Member

    I ignore lid too and set short auto sleep times so it's only running a few minutes max. It eventually suspends and wakes up correctly without loops. Suspend from power menu also works perfectly.

    16.04 with 4.6 rc5
     
    Mikeal likes this.
  5. urbanBlacklab029

    urbanBlacklab029 New Member

    where do you define the auto sleep timers?
     
  6. Updating the kernel looks scary to this newby. I'll keep waiting.
     
  7. urbanBlacklab029

    urbanBlacklab029 New Member

  8. Hmizer

    Hmizer New Member

    Upgrade to the 4.6rc5 kernel and now I can finally suspend!
    Thank you.

    Uh...So suspend works but the two nvidia drivers I've tried so far (361 & 364) result in login screen loops. Have to purge nvidia to fix...
     
    Last edited by a moderator: May 7, 2016
  9. I just upgraded to 4.6rc5 and am using 361.42. Have suspend now and no issues with login screen loops. I'll have to test suspending with lid close later on.
     
  10. Hmizer

    Hmizer New Member

    Please update. I tried going to the 361.42 driver but got the login loop problem :-(
    I'm not currently gaming in linux but would like to be able to ASAP so W10 doesn't need to grace my screen.

    Thanks.
     
  11. Suspending by closing the lid puts mine into a suspend loop upon logging back in each time. Setting the power button to suspend, or suspending the Gear -> Suspend both perform normally. The closing the lid is a minor annoyance that I can put up with. Ill just suspend it with the power button.
     
  12. Hmizer

    Hmizer New Member

    I was more interested in the nvidia driver success. When I tried it I got the login loop.
     
  13. Oh, sorry made that original post quickly. That's what I meant by "am using 361.42". I'm on Nvidia 361.42 and that is what my results are right now.
     
  14. Hmizer

    Hmizer New Member

    Did you install from the third party drivers tab in settings or did you install manually?

    Thanks
     
  15. Yeah, I left it installed from the third party drivers tab before I upgraded the kernel. And it was just working. Wish I had an in depth perfect method for the way I did it, but it was that simple haha.
     
  16. Hmizer

    Hmizer New Member

    Well, thanks anyways. If I install 361.42 from the third party drivers tab I just get the login screen loop bug :slightly_sad:
     
  17. mdaly001

    mdaly001 Active Member

    hey I just got the 2016 blade and am getting weerdd interaction. If i switch the nvidia prime to the intel I cannot shutdown or reboot the comp. It just hangs. But if I am running on the 970m I have no issues. I would love to have it running on intel to save battery life. Has anybody else run into this. BTW I do have the login screen loop bug if i close the screen. I have just been making sure to shut down.
     
  18. OHFISHAL_Batman

    OHFISHAL_Batman New Member

    Neat idea! Hope it works out! :wink_:
     
  19. plainfaced

    plainfaced New Member

    Great to know some people are running Linux.

    What was my daily driver (2011 MBP) died the other week.. I had built a gaming PC around 6 months earlier.. My first PC in many years.

    I am missing the portability of a Laptop though... So I have been on the search for around a week now.

    I installed Ubuntu 16.05 on my PC a week or so ago, and now use it for my general PC needs.. Windows for Gaming and music production.. So I would love to put Ubuntu 16 on whatever Ultrabook I decide to go for.

    I think it might just be the Stealth.

    Now I just have to decide, whether to Dual boot or not?
     
  20. Her0Zer0

    Her0Zer0 Member

    For those of you still following this thread, figured I'd give an update on installing Ubuntu 16.04 on a New Blade 14 2016 model. It took a few extra steps.

    - Razer Blade 14 256 GB Signature Edition purchased from Microsoft Store
    - Upgraded Windows 10 Home to Windows 10 Pro
    - Created USB Recovery Stick from Windows 10
    - Removed OEM 256 GB M.2 NVMe SSD and replaced with Samsung 950 Pro 512 GB M.2 NVMe SSD. First drive was write protected, Amazon replaced - second drive worked
    - Restored Windows 10 Pro installation
    - Created Ubuntu 16.04 USB Boot Installer
    - Shrunk Windows 10 partition by 183 GB (150 GB for root, 33 GB for swap)
    - Disabled UEFI in BIOS
    - Boot into Ubuntu 16.04 install
    - Check install from third party source (Allow updates from internet disabeld - annoying)
    - Choose custom install
    - Create two partitions in free space: 150 GB for / and 33 GB for swap
    - Choose /home to be encrypted
    - Grub boot works - but Ubuntu hangs on startup screen
    - Drop to Advanced Boot - low graphics installation
    - Get to shell
    - First need to fix wifi - pulled the firmware files listed here to a USB drive and copied to Razer as instructed: https://bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1520343
    This worked on reboot but still needed to connect to network via command line. Hint: nmcli device <device id - use iwconfig to find the name> connect <access point> password <WPA password>
    - Use apt to update, upgrade and dist-upgrade installation
    - Still not working to login but first want to get the working 4.6rc5 kernel installed from mainline. Created executable script directly from the 64-bit section here and worked perfectly: http://sourcedigit.com/19536-how-to-install-linux-kernel-4-6-rc5-on-ubuntu-16-04/
    - Finally, need to fix nvidia drivers. Followed the top voted answer right here to basically purge existing nvidia drivers, add an nvidia repo, install the nvidia-364 package + reinstall ubuntu-desktop and upstart: http://askubuntu.com/questions/7609...-installing-ubuntu-16-04-with-nvidia-graphics
    - Ubuntu 16.04 boots nicely to desktop!

    Ok so still not everything working perfectly. Mouse, keyboard and wifi seem to be fine. Video is mostly working, though I tried playing a video on VLC and it was a mess with no sound but this was whatever version of VLC was in the default repo. Native video player did better after it prompted to update for appropriate library - but no sound. Will need to see about that but pretty sure it's easy enough to fix. Also used grub-customizer to make Windows the first and thus default boot option. Also seeing some really annoying problem with cryptswap1 prompting for a password all the time. Have fixed this before but will need to do again. Will try latest VLC version + whatever is the latest NVidia native drivers if it isn't 364. Overall took a couple of hours but worth it to have Ubuntu dual booting. For those interested, Chroma seems to keep the same pattern defined in Synapse so that's the only way to change things - though I did find some posts on Ubuntu drivers being on the way.

    Will update once I get the kinks worked out. But safe to say, this laptop is really superb right now. Could be a slight bit brighter on the screen and annoyed with the backlit keys not showing the symbols (and putting the symbols UNDER the key letter - why????). But so minor considering what a beast this machine is - in such a sexy package!

    EDIT: Samsung 950 Pro HIGHLY recommended. Completely changes performance - laptop can cold boot to Windows or Ubuntu in about 7 seconds. Phenomenal
     
    Last edited: Jul 6, 2016
    SladeNoctis and jcecil like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >