Razer Blade 15 (2022) - Suspend issues (BIOS update?)

Discussion in 'The Linux Corner' started by themarpe, Apr 21, 2022.

Thread Status:
Not open for further replies.
  1. themarpe

    themarpe New Member

    Hi

    Testing out latest Ubuntu 22.04 on Blade 15 - 12th Gen Intel system, and having some issues with going to suspend on lid down or when explicitly calling the suspend function.

    I've tried modifying the sleep mode from s2idle to deep, and modifying it in GRUB to reflect the changes along with increased swap size for possible hibernation mode, but still wasn't able to make it work.
    It seem like it wakes back up immediately (maybe woken up by another peripheral) or the fan never stops spinning. (also logging back in takes way too long compared to normal system)

    Kernel also logs a lot of ACPI errors, which seems to kinda point to this being a BIOS issue, not letting Linux know about power states correctly?

    Regardless, I'd love to get some thoughts on this, especially regarding any customizations anyone has done, or maybe a more appropriate distro, etc...

    (Also as a side note, to use the WiFi on the 2022 Blade, make sure to use >5.16 kernel - this was the first thing on the to do list to get things up and running on this machine :) )
     
    mavinii likes this.
  2. RocketdyneF3

    RocketdyneF3 New Member

    Hello,

    I have the same machine and have been documenting my fixes here:

    https://abarry.org/ubuntu-on-razer-blade-15-2022-advanced/

    The line you want is:

    echo RP05 | sudo tee /proc/acpi/wakeup

    I was unable to work around the laggy touchpad issue with s3 suspend and have been using s2idle. Most of the time my power consumption is low, but occasionally I find it goes nuts and the laptop is dead in the morning. Still trying to track that down.

    Also haven't fixed the microphone yet, let me know if you hear any ideas for that.
     
  3. RocketdyneF1

    RocketdyneF1 New Member

    (sorry was getting Access Denied on so I thought I might need a different account. Turns out my message was just too long, please reply to this account)
     
  4. themarpe

    themarpe New Member

    Hi RocketdyneF1

    Thanks for all off the information.

    In the upcoming days I'll be playing around with various settings much more. For now I've set up the sleep as you've mentioned in your blog. I still had the deep sleep setting from before, but it seems that it atleast doesn't wakeup after going into suspend now, with your changes added.

    I've yet to measure any power draw in this configuration. Will report back.

    By S3 do you mean deep sleep, and with laggy touchpad a really slow movement of the cursor?


    I'll look into the microphone issue more, hopefully something can be done about it.

    Regarding the fan - would it be possible to manually set it to 0 (once/oneshot) at the "suspend event" similar to the NVidia situation?


    Regards
     
  5. RocketdyneF1

    RocketdyneF1 New Member

    Yes exactly.

    I have noticed that fan is on during s2idle but turns off as the system cools. I tried to manually control it inside linux and have not succeeded so far.

    Glad that you can at least suspend now. I'm all ears about the sound/microphone issues and if I make more progress I'll be sure to report back.
     
  6. chadhq

    chadhq New Member

    Thanks for all of the info here. I just picked up the same 12th Gen 3070 Ti model, Running nicely thanks to these tips :)

    I have not been able to get the 1440 display to run higher than 60hz though. Anyone else had success there?
     
  7. RocketdyneF1

    RocketdyneF1 New Member

    I did at one point I think by disabling the Intel GPU in the bios, but that breaks a bunch of other functionality. I do not have the option to run it at 144Hz with my current configuration.
     
  8. chadhq

    chadhq New Member

    Oh fascinating - I hadn't tried that. But can now unblock the 240hz enabling 'Discrete Intel' graphics only.

    The downside I see is that waking back up from suspend causes crazy Gnome rendering o_O

    I mostly use i3wm so doesn't affect me too much. Though, it is interesting. Games now run at very high res, but Gnome and browsers don't render at high refresh rates. Perhaps gnome never does though? Also I wouldn't have expected games to run using only the 'Discrete Intel' graphics only, so i don't trust that that setting is being honoured. Oh well, will keep investigating :)

    I guess in hindsight, If i'd realised that I couldn't get high refresh rates, I'd have opted for the 4K screen instead. Oh well, I'm still very happy with the machine, and always new i'd be miss out on a few things with linux.
     
  9. RocketdyneF1

    RocketdyneF1 New Member

    On my machine, when you set to Discrete only it's like the Intel GPU doesn't exist. So I expect you are getting great performance but bad battery life. If I remember correctly, I also was unable to change the screen brightness in that mode. Does that work for you?
     
  10. chadhq

    chadhq New Member

    Oh yes of course, I totally misread the intent of that setting. makes sense :)

    And now that I have retested, you are correct, I cant change the screen brightness :-/ Thats a bit of a no go really. I'm going to try solve that problem.

    I've discovered running echo 50 | sudo tee /sys/class/backlight/nvidia_0/brightness will set the display to 50% brightness, I just need to confirm whether thats actually working at the hardware level though, and not a software thing. Worst case, i'll make a little script and bind it to the function keys, but I'll do a little more digging first.

    Still, as you say, the battery drain is epic.
     
  11. chadhq

    chadhq New Member

    I should also add, I see a lot of screen tearing when running in discrete mode only. (under both Gnome and i3wm with Picom). Will continue to play around with compsitors too see if I can resolve that. But i get buttery smooth non tearing on my other machine with Radeon gpu using i3wm + picom.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >