Razer Blade Stealth Updater Problem

Discussion in 'Systems' started by imperialcantaloupe1, Jul 22, 2016.

Thread Status:
Not open for further replies.
  1. imperialcantaloupe1

    imperialcantaloupe1 New Member

    Hello again, I've attempted to fix my Core problem using various methods, but I think the root of my trouble lies in the Stealth Updater Tool. Every time I attempt to use it I get an error message that reads, "This firmware tool is for use only with Blade Stealth and compatible system.The application will now close." I am in fact using this on a 128 GB QHD Blade Stealth, if anyone knows anything about this I could greatly use the help.
     
  2. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Have you tried contacting razer support? Sounds like something they could help with :)
     
  3. imperialcantaloupe1

    imperialcantaloupe1 New Member

    I have! I'm just looking for a more immediate solution-
     
  4. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Ah okay. I don't have a stealth, but is it part of the OS? Or a separate program like synapse? If separate program, have you tried uninstalling and reinstalling it? Or if its part of the OS, have you tried a fresh install?
     
  5. imperialcantaloupe1

    imperialcantaloupe1 New Member

    I have tried reinstalling it a number of times to no avail. I just don't understand how it thinks this isn't a Stealth.
     
  6. Katana_x_II7

    Katana_x_II7 Well-Known Member

    Hm...yeah thats super weird. Maybe your stealth has a slight hardware issue that prevents the software from recognizing its a stealth? Not sure there is much else to try, except to wait for support to get back to you. I hope you get it figured out!
     
  7. MoodyKhader

    MoodyKhader New Member

    Exact same issue please tell me how to fix it,

    My laptop was RMD'D 3 times, and all of the times the same issue stayed the same, and I am beginning to believe it's a faulty Core. So please Update me, for I've done mostly everything from flashing BIOS, to Reseating Graphic card

    This issue I'm getting is my prephirals are super laggy, and the GPU is not the very well functioning
     
  8. imperialcantaloupe1

    imperialcantaloupe1 New Member

    I was able to resolve my issue by wiping my computer and uninstalling and reinstalling the Thunderbolt 3 driver. I didn't need the Updater after all-

    Hi guys, just uninstall the updater if you do not have Razer Core, that's only specific updater to work on Razer Core and Blade Stealth. Your issue will be resolve after un-installation.
     
    Last edited by a moderator: Aug 13, 2016
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >