The New Razer Blade and Razer Core

Discussion in 'Systems' started by Yeppers, Jul 26, 2016.

Thread Status:
Not open for further replies.
  1. Yeppers

    Yeppers Member

    Is anyone using the Core with the New Razer Blade (not the Stealth)? If so what steps outside the normal ones that Razer posts did you have to do to get it working?

    I followed the steps on from here for the Blade http://www.razerzone.com/gaming-systems/razer-core-updates and followed the steps in the Master Guide http://dl.razerzone.com/master-guides/RazerCore/CoreOMG-ENG.pdf.

    My issue is the Blade and Core keep loosing connection to each other often. The Core is still on when this happens because the fans are still running however the lights are not on. Restarting the laptop and/or unpluging the Core and Plugging it back in don't seem to help. The only work around I have found is to start the laptop, login to Windows, close the laptop lid so it goes into sleep mode and then open the laptop lid. It will still connected for a while this way but it sometimes still disconnects.
     
  2. Razer.WolfPack

    Razer.WolfPack Community Specialist Staff Member

    Hey @EpicFlail seems like you're encountering some issues with this have you tried reaching out to our Support Team about this?
     
  3. Yeppers

    Yeppers Member

    I did via phone and I was emailed a list of things to try that were just reworded steps of the install process so it wasn't much help. They told me they were advancing the case up but that could take 24-48 hours for a response so while I wait I thought I would ask the community to see if someone could point me in the right direction faster.
     
  4. Eason85_no_id

    Eason85_no_id Member

    The magnetic sensor might be defective. You can try bending the rail like has been described in the other thread about razer core disconnects.
     
  5. Yeppers

    Yeppers Member

    Great find I am going to try that when I get to work today.

    I promise I searched the threads first but I guess I used the wrong terms ;)
     
  6. Eason85_no_id

    Eason85_no_id Member

    The razer core also sometimes needs to be power cycled (like unplugged from the wall) before it will properly start up. That's when it's used with non-tested laptops.
     
  7. Yeppers

    Yeppers Member

    Eason85 likes this.
  8. Yeppers

    Yeppers Member

Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >