2019 15" Razer Advanced OLED w/Linux Mint 19.1 Experience

Discussion in 'The Linux Corner' started by CBMAmiga, Jul 8, 2019.

  1. CBMAmiga

    CBMAmiga New Member

    Greetings all,

    I wanted to post my setup and share what I have working and what I don't in Linux. Like others, I am coming from a MacBook Pro (2015) after many years. I am a developer for both the web and Windows (via Parallels) spanning all kinds of industries (VR, AI, Database, etc). This is my first Razer product and I have found this notebook to be well built with a great display..

    I have installed Linux Mint 19.1 (dual booting Windows 10 upgraded to Pro) and did the following:

    -upgraded to Kernel 5.1.16 (disabled Secure Boot)
    -installed the Intel ucode driver to get WiFI working.
    -installed the Nvidia drivers for the GPU
    -For screen brightness I use xrandr --output eDP1 --brightness 0.5 (for 50%) in the terminal
    -Installed xscreensaver (amazing savers)
    -Installed TPL for power management
    -Installed VMWare Workstation 15.x for Windows 10 inside Linux so I can dump dual booting at some point
    -Was horrible to install
    -Does not detect audio even though I have audio in Mint
    -Tried a number of fixes for the audio but they did not work
    -Seems laggy compared to VMWare Workstation under Windows running the same VM


    I would like to see:

    A better power management tool that gives you more information
    A simple slider for adjusting screen brightness


    I will post more as I add more.
     
  2. SaltySailor

    SaltySailor New Member

    I have had audio problems in Mint 18.3 after booting into Windows (2017 Blade w/7700). I am suspicious that this is a result of using "restart" in Windows then selecting Mint in grub. I went back to Windows and did a full shutdown, then started fresh with grub to Mint - no problem. It may also have something to do with updating Win 10. Anyway, once gone it seems to stay gone - but I don't use restart to switch between OS anymore.
     
  3. ThT86

    ThT86 New Member

    @CBMAmiga is your backlight keyboard keys and in general is the screen backlight working without issues excluding using the xrandr command (this just modifies the gamma value and not the actual screen brightness)?

    I am with archlinux and in my case is not working at all neither if I try to manually set the brightness value with xbacklight. I also tried with the live cd from the last ubuntu and manjaro and the screen brightness is also not working there.
     
  4. lminer78

    lminer78 New Member

  5. ThT86

    ThT86 New Member

  6. lminer78

    lminer78 New Member

    @ThT86 how has the intel card worked for you? I've noticed pretty bad (jerky) performance with screen tearing. Are you using any special drivers?
     
  7. ThT86

    ThT86 New Member

    I am having issues with the intel driver as well. You can check here https://bbs.archlinux.org/viewtopic.php?pid=1857824#p1857824 the thread that I have created in the arch forums. Using "xna" seemed to partially work for a moment but finally I am back at the same situation. It might be an issue of the xorg-server though as stated in the last posts.
     
  8. JkGemma

    JkGemma New Member

    Hello, could you provide link/tutorial to do these step ?

    Thanks !
     
  9. ThT86

    ThT86 New Member

    guys have you managed to get some output with the nvidia drivers over the hdmi/thunderbolt ports? Here I am having issues, and though the devices are detected I cannot get any sound from them.
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >