Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. _ramsey_

    _ramsey_ Active Member

    I'm wondering if anyone here has installed linux on a new blade. From what I read after some googling, the major problems involved the track pad, but after some months people started getting it working. If anyone has had any experiences, good or bad with linux on a 14" blade, I'd love to hear them :)

    I've jumped in with both feet. I downloaded unetbootin and used it to created a live_x64 usb stick for ubuntu. I rebooted the Razer, pressed F1 to go into bios and booted from said stick. I installed ubuntu 14.04.1 with full disk encryption and home folder encryption. Everything seems to work so far. I'm now trying to update the trackpad so I can do two finger scroll and two finger right click. After that I'll look into installing nvidia drivers and CUDA tools. The only thing I saved from Windows 8 was the Razer wallpaper :)

    Great success :D I know at least one other person here (@Adeni ) is interested in this so I'm posting for everyone. Also, posting it in case I have to do it again in the future.

    After some fiddling I've gotten my nvidia drivers running on ubuntu. Here are the steps I needed to take to make it happen.

    I installed Ubuntu 14.10 from a usb stick. x64 version. Once that was installed, I let the software updater run updates and reboot. Then I open terminal and

    sudo apt-get update
    sudo apt-get upgrade
    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get install nvidia-346-dev nvidia-prime bumblebee-nvidia mesa-utils

    at this point, I go into

    /etc/init/gpu-manager.conf

    and comment out every line of that file with a # at the beginning of the line. I'm still not sure I need this, but I'm under the impression that if this isn't done, it messes up your xorg.conf or something on reboot.

    I could check with glxinfo (installed with mesa-utils) to see I am running intel graphics

    glxinfo | grep OpenGL

    then I switch to nvidia graphics with prime-select (installed with nvidia-prime)

    prime-select query
    >unknown
    prime-select nvidia
    prime-select query
    >nvidia

    At this point, you'll need to restart. I didn't restart and I tried glxinfo again, but it threw an error. I also tried running nvidia-settings, but it didn't show that my driver was loaded.

    So, restart ubuntu. Here's where something panic inducing will happen. After booting the screen is black. Just nothing. Doesn't even look like the backlight is on. Don't ctrl-alt-F1 yet! Just close the lid and wait for the razer logo on the lid to dim indicating the laptop went to sleep. (See, you guys that don't like the backlight logo, it's useful. Score one: Razer!) Now, open the lid back up and the laptop should wake. If not, just hit the up arrow key or something. Anyway, when it wakes, the black screen flashes some white terminal text too quickly to read and then the password screen comes up!

    Log in and

    glxinfo | grep OpenGL

    And you should see that your nvidia graphics is now active. Running nvidia-settings likewise is much more interesting.

    At this point, your drivers are done. But if you're like me, you will want to install NVidia's cuda toolkit for development too. I tried installing the nvidia-cuda-toolkit from the xorg-edgers ppa, but I couldn't find where it installed the toolkit other than the binaries, which wasn't very useful. So I removed that and downloaded the cuda-7.0 .deb from nvidia instead. Installing that goes like

    dpkg -i *.deb
    sudo apt-get update
    sudo apt-get install cuda

    then in ~/.bashrc I added

    export PATH=/usr/local/cuda-7.0/bin:$PATH
    export LD_LIBRARY_PATH=/usr/local/cuda-7.0/lib64:$LD_LIBRARY_PATH

    save that and then run

    cuda-install-samples-7.0.sh ~

    To install the sample code in the home directory. After that, I

    cd ~/NVIDIA_CUDA-7.0_Samples/1_Utilities/deviceQuery/
    make
    ./deviceQuery

    To build and run a very basic sample cuda app. So, that's it. I'm still not sure if I needed the bumblebee-nvidia install, but it doesn't seem to be causing any harm.

    Hope that was interesting to someone :)
     
    Last edited by a moderator: Aug 13, 2016
    kellerbaum, rjzak, shivalkira and 8 others like this.
  2. Destrok

    Destrok Well-Known Member

    You can always make a partition and keep the default windows on one and run linux on the other until you are comfortable with it. That is what I did with an old laptop when I was first experimenting with linux.
     
  3. _ramsey_

    _ramsey_ Active Member

    In my case, I'm way more comfortable with Linux. If I couldn't get Linux to work on this laptop, I'd sell it ;)

    I needed a ~40 second video to explain to me how to power off Windows 8.

    http://windows.microsoft.com/en-us/windows-8/how-shut-down-turn-off-pc

    The mere existence of said video seems to indicate I'm not alone.

    I did briefly consider it. Doing that would have made full system encryption more difficult than clicking a single checkbox though, so I just erased Windows.

    Everyone complains about the Razer Blade's price. Wouldn't it be sweet if they'd ship with Linux as an option and save us all ~$100 or so on the OEM license fee for Windows? Better and lower priced. What's not to like? :cool:

    Now if I can just fix that black screen on boot and the trackpad, my Blade will be perfect. I'll post here as I find my answers.

    BTW, I removed bumblebee-nvidia with no ill effects. Also noteworthy,

    dmesg | grep nvidia
    [ 8.644966] nvidia: module license 'NVIDIA' taints kernel.
    [ 8.647534] nvidia: module verification failed: signature and/or required key missing - tainting kernel
    [ 8.652041] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
    [ 8.652385] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
    [ 9.215116] nvidia 0000:01:00.0: irq 50 for MSI/MSI-X
    [ 38.814107] nvidia_uvm: Loaded the UVM driver, major device number 249

    I may try reinstalling and running NVidia's driver .run package instead of using xorg-edgers. That offered me a way to sign the drivers and possibly get rid of the message above. In any event, it looks like a big scary warning, but the drivers work just fine anyway.
     
    Last edited by a moderator: Aug 13, 2016
  4. Philak

    Philak Active Member

    If I had the money to get a blade I'd probably do the same thing. I prefer Ubuntu to all th other OS's going. Its just frustrating sometimes with the lack of support with some programs/games.
     
  5. ProudSikh

    ProudSikh Member

    This is a known issue with grub when its booting up using nvidia drivers. Edit your grub.conf (should be /etc/grub2/grub.conf) and uncomment the "GFX_MODE"(i believe thats what its called) and add your own resolution as the argument.

    This is what fixed the black screen boot for me on my dev macbook pro. Im glad the new blade likes linux, its hard for linux to not work on every computer but specific hardware still causes issues because manufactures are dumb about how they make stuff. The "windows way" needs to die, hard.
     
    Panaman likes this.
  6. _ramsey_

    _ramsey_ Active Member

    Hmm, I have /etc/grub.d/ but no grub2. I also have /boot/grub/grub.cfg, but I don't see GFX_MODE anywhere in it.

    Yay! Trackpad is working now. Following the instructions here:

    https://wiki.archlinux.org/index.php/razer

    Which is the following:

    sudo apt-get install git
    git clone https://github.com/aduggan/hid-rmi.git -b rb14
    cd hid-rmi
    make
    sudo make install
    sudo depmod -a

    I got an error in the build at 'make' on Ubuntu 14.04, but 14.10 built it without issues. Two finger scroll works, two finger tap to right click works. Now if I could just get rid of the pesky black screen on boot, it will be perfect.
     
    Last edited by a moderator: Aug 13, 2016
  7. ProudSikh

    ProudSikh Member

    Sorry about that. I gave you the wrong path. I verified yesterday with my ubuntu install. Its /etc/default/grub

    The line your looking for is GRUB_CMDLINE_LINUX=""
     
    _ramsey_ likes this.
  8. _ramsey_

    _ramsey_ Active Member

    In there I see the line you mentioned. It's uncommented and exactly as you mentioned. Below it, I also see

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    I assume this is where I could change that to GRUB_GFXMODE=3200x1800, or do you mean I should make the line you mentioned to:

    GRUB_CMDLINE_LINUX="GFX_MODE=3200x1800x24"

    or something similar?

    After googling a bit, it seems after I modify the defaults, I should

    grub-mkconfig -o /boot/grub/grub.cfg

    Just to note, if I switch to intel graphics, log out, and log in, there's no problem. If I switch to back to nvidia graphics, log out, it's the same problem. Screen goes black. I have to close the lid and wake from sleep to get the screen back. Does that still sound like the bootloader? I mean, I'm already booted. Just logging in and out.
     
    Last edited by a moderator: Aug 13, 2016
  9. razervinh

    razervinh Active Member

    Have you tried installing the NVidia driver the "hard way"? (It's actually not really "hard", but some people consider it "hard" when you have to use the console.) This webpage has the correct info:

    http://monsterbeee.blogspot.com/2013/12/my-notes-manually-install-proprietary.html

    Basically, you're downloading NVidia's driver build script, installing development tools (gcc, make, kernel development), setting some things up and running NVidia's script to build and install the driver.

    The webpage is for openSuSE, but should be the same, except for step 5, which is probably unnecessary in this situation since you're already on NVidia drivers instead of the open source Nouveau drivers. Step 2 would need to be Ubuntu's installation method instead of openSuSE's zypper.

    My desktop always needs the NVidia driver as Nouveau gives me a corrupted screen. Every time I install a new kernel or update to a major release, I just boot into console mode, run the NVidia script and I'm back up and running.
     
  10. _ramsey_

    _ramsey_ Active Member

    I did that first actually :) The problem there is the xorg.conf is all messed up whenever nvidia-xconfig is run. You get a screen, but it looks about 640x480. Even doing the steps I describe above, if you run nvidia-xconfig afterwards, it really messes it up.
     
  11. Nocathegoat

    Nocathegoat Member

    I mean, really? Linux on this beast? That's like going to the second-hand clothes store with an iphone and a ferrari :stuck_out_tongue_winking_eye:
     
  12. ProudSikh

    ProudSikh Member

    Ive never had to run the grub-mkconfig command but I messed up when I said look for GRUB_CMDLINE_LINUX in my second reply to you. I was actually setting my SSD to stop timing out so thats why I remembered that specific line. The line that you should edit is the Commented GRUB_GFXMODE like I initially stated in my first reply. As you can tell I've been working on this stuff recently and am confusing myself when trying to type a reply to you and other forums.

    So uncomment GRUB_GFXMODE and set the resolution to something low, no need to set it to 3200, it'll also look tiny and bad cause there's no scaling. So set it to like 1280x720. Its only grub so it won't hurt. Do that and reboot and see what happens.

    No thats like running windows 8 on this thing. But everyone prefers something different so don't knock it.
     
    Last edited by a moderator: Aug 13, 2016
  13. _ramsey_

    _ramsey_ Active Member

    LOL, I get it. Free software on expensive laptop.

    Well, I did kinda start it with my comments on #5 :oops:

    Anyway, to each his own. Gamers love Windows, programmers prefer Linux. Both for obvious reasons. Maybe I'll even try a little gaming on this machine whenever I get some free time :D
     
  14. Nocathegoat

    Nocathegoat Member

    Well im not trying to make you buy an apple product instead of a Razer(cause all hail Razer) but a Mac laptop is probably the best choose for work
     
  15. ProudSikh

    ProudSikh Member

    You didn't really start it because unless you extensively kept up with the changes that were being made in windows 8, taking 40 seconds to shutdown is not unheard of. As an IT guy I've heard it from everyone (family friends co workers).

    I agree with this. I have a retina macbook pro and love it. Bought it around release time. With the new Blade, I'm considering getting it, only if I decide to play games while I'm working on it. I can't see myself gaming on a laptop because of the neck strain. But besides buying a macbook, the blade is now an option and I love it. Other manufacturers need to step up. I loved the Lenovo Thinkpad X1 Carbon, but lenovo has over the years made some stupid and poor decisions that aren't helping them.
     
    Last edited by a moderator: Aug 13, 2016
  16. razervinh

    razervinh Active Member

    I have an 11" Air for travel purposes and at the time, 2013, the GNU/Linux drivers weren't ready for it. I totally want GNU/Linux on it, to match my desktop setup. I have an older Acer 11" netbook, which has GNU/Linux openSuSE 13.2 as the base system and Windows 7 in VirtualBox, as another traveling device. It's just so nice to be able to install the latest OS on an older system, such as the Acer. No worries about MS or Apple pulling the upgrade plug.

    Have you seen the new Dell XPS-13? It's the size of the 11" Air but with a 13" screen due to a 5mm bezel. I think Dell is beginning to step it up. It's too bad they can't offer the Trackpoint of the Lenovo's.
     
  17. ProudSikh

    ProudSikh Member

    Linux on MacBooks has gone a long way since the 2nd gen air was introduced and the first core i7 macbook pro was introduced.

    There's a few minor things that don't work in the retina macbook pro or macbook air, but its the same things (webcam, etc). But majority of things work great. Im using a 13' 2014 MBP as my *Nix laptop and LOVE it. I bought it because for the price I got it, only the X1 was up there, but the lack of a decent keyboard, stupid touch panel with rotating buttons and the god damn screen turned me off.

    I stay away from Dell and HP like the plague, it "looks" impressive, but people are already bitching about windows 10 on the XPS 13, i can only imagine how horrible linux would be.

    Im waiting to buy a air as soon as a retina version is announced. The air has been the perfect laptop for couch/linux/etc. The only thing that bothers me is the resolution. It has a good resolution when it came out, but I want hidpi retina resolution
     
  18. _ramsey_

    _ramsey_ Active Member

    I used Apple hardware exclusively from 1997 to 2013. I have so many reasons why I don't want one any more. Listing them would only start a flame war and detract from the topic of the thread though :stuck_out_tongue_winking_eye:

    I would like to correct some older information I found via Google.

    Misconception 1) Function brightness keys DO work for me. I read on an older post somewhere that they did not.

    2) Touchpad is awesome after applying the patch I mentioned earlier. 1 finger tap. Tap and a half to drag. Two finger tap for right click. Two finger scrolling. Three finger double tap brings up app switcher. Four finger tap brings up the ubuntu dash. Everything I've tried has worked. The only thing I wished I could adjust would be trackpad speed. The fastest setting was still slightly slow to me, but I've already gotten used to it. The speed is probably fine, there's just so many pixels on this screen :D

    3) Graphics drivers. Aside from the black screen issue I mentioned, I haven't noticed any instability or problems yet.

    Overall, I'm super pleased with it. I hope other Linux users considering the purchase of a new Blade find this post helpful. Or you know, maybe Razer management will see this and think "Hey we could ship with Ubuntu pre-installed." That would be ultra-mega-awesome too.
     
    razervinh likes this.
  19. razervinh

    razervinh Active Member

    I check every now and then to see the state of things with GNU/Linux on the 2013 Air and it seems like this year might be the year I install it. Most of the successful installs reported have been with Arch and Ubuntu and I prefer openSuSE, which means I should probably dedicate a block of time to install, in case something goes wrong.

    There's supposed to be an Ubuntu version of the XPS 13 coming, similar to previous version Dell has been offering in the past.

    For 11", the resoluton has been fine for me. I only wish the display was better. The viewing angles aren't that much better than my cheapy Acer netbook. If you're off center, colors are off.
     
  20. _ramsey_

    _ramsey_ Active Member

    Still haven't figured out the black screen thing, but I don't believe it's Razer specific. I started a thread on the nvidia devtalk forums about it and it seems others on different hardware experience the same thing. Hopefully NVidia will fix it with a driver update release. I've also noticed the mouse cursor disappears when it's along the very top edge of the screen. Both of these are minor annoyances at worst.

    I have noticed a new issue. This time with sound. It seems when I'm on battery power I get a popping sound from the speakers/headphones. It sounds like it is trying to go into a low power mode on the speakers, but then it comes back on, ad nauseum.

    I rebooted on battery power and when I did I get the "Problem detected" dialog and an option to send a bug report. That came up twice until I pluged in the laptop. Once plugged, it stopped.

    And in dmesg, I see

    [ 1588.256098] sound hdaudioC1D0: hda-codec: out of range cmd 0:20:400:ffffcfff
    [ 1636.844092] sound hdaudioC1D0: hda-codec: out of range cmd 0:20:400:ffffcfff
    [ 1647.948092] sound hdaudioC1D0: hda-codec: out of range cmd 0:20:400:ffffcfff

    repeating.

    It seems I can make the popping go away by disabling the powersave.

    http://www.foxswap.com/computers-and-technology/ubuntu-12-04-clicking-sound-from-speakers/

    In:

    /usr/lib/pm-utils/power.d/intel-audio-powersave

    Commenting out:

    INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

    And adding underneath it:

    INTEL_AUDIO_POWERSAVE=false

    solves the issue, though I would prefer to save power. The battery appears to drain very quickly with the nvidia gpu enabled. I'm going to let it drain to see how long it lasts, charge up, then try again with intel graphics and see what difference there is.

    My battery life observations on a brand new blade (QHD+) with Ubuntu 14.10 installed.

    With the nvidia GPU selected, 1% per minute for about 1:40 run time on battery before automatic suspend. I depleted the battery this way to make sure it wasn't a battery calibration thing. With the intel gpu enabled, it appears to be a little better than 2% per minute. (Down 10% after 21 minutes of usage). This is just web browsing/watching youtube in both cases. So it should last about 3:30 away from a wall socket. Charging to full battery takes about 2:25.
     
    Last edited by a moderator: Aug 13, 2016
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >