Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. illathon

    illathon New Member

    I did use the official drivers from the Nvidia site and it worked well with 14.04... I also got a good 6 hours while running on intel. I think I used Cuda 7.5 though.
     
  2. geoworldFreshAir868

    geoworldFreshAir868 New Member

    I just bought a Razer Blade QHD+ and followed Stephen O’Hair guide.

    I made the switch from Mac (cos they have began to suck lately, but have been using them for more than a decade on a daily basis) and moved back to good all Linux (Uni when I had the time to build from scratch and play around with Gentoo).

    It's still a bit of a disappointment that Desktop version of Linux still suck big time (compared to Mac OS X ofc). Something that simple as 'tweaking' in unity that cursors should be large, are reset on reboot (minor stuff) but something that should work like the nvidia graphics (Linus says it correctly at a lecture at his old uni) doesn't work and I get flickering when I run the recommended drivers by Ubuntu:[​IMG]
    (already tried the compiz settings stuff but doesn't work)

    Well I guess there is no way around than spending the next couple of months trying to fix this, until then, no DOTO for me :)

    Note: When clean, no W10 partition
     
  3. mdaly001

    mdaly001 Active Member

    Im running 15.10 on the stealth... been pretty stable. Only annoying issue is the wifi... but I do have a feeling it is the wifi card. it is finicky in both my windows and linux partitoins... sometimes it doesn't register on boot so I have to reboot but its not the end of the world.
     
  4. geoworldFreshAir868

    geoworldFreshAir868 New Member

    What about the Nvidia issue with the "Flickering"? I tried following:

    https://www.marcus-povey.co.uk/2015/01/08/fixing-nvidia-flickering-on-ubuntu-14-04-with-gnome/

    Without any success ...

    Note: Is you Nvidia also GTX 970M?
     
  5. illathon

    illathon New Member

    Running 14.04 with the new kernel works perfectly. Then I download the nvidia drivers from the site with cuda. Version of cuda is 7.5 I am using and then cuda installs 352 of the nvidia driver for you.

    https://developer.nvidia.com/cuda-downloads

    That adds a new apt source directly to nvidia.

    Only small issue is one of the usb ports gets turned off when waking up from suspend, but if you reboot it works. Otherwise two other usb ports work.

    No more need to do any extra stuff. Just make sure you install the wily kernel 4.2 so you get gesture support on the trackpad.

    It is in the repos so simple to install something like
    sudo apt-get install linux-image-generic-lts-wily

    Also wifi works much better in 14.04 for some reason. I tried newer versions and it had problems. Seems like a regression. Wait for the next LTS and I am sure it will be fixed in April and you can upgrade from 14.04 if you want. I personally stay on LTS version until they reach end of life, or I get a new system. Steam works great.
     
  6. mdaly001

    mdaly001 Active Member

  7. _ramsey_

    _ramsey_ Active Member

    In the year I've had this 2015 Blade running Ubuntu, I have not once experienced flickering. At all. I've installed 14.04, 15.04, 15.10, drivers with xorg edgers, drivers through the additional drivers panel. Never anything I would describe as flickering. Not even once.

    Obviously, I'm not saying you are not experiencing it. I'm just conveying my experience so you know it _is_ working for someone. Maybe there's something missing/extra you install that causes it?
     
  8. geoworldFreshAir868

    geoworldFreshAir868 New Member

    Installing CUDA, worked like a charm :)

    NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery$ ./deviceQuery
    ./deviceQuery Starting...

    CUDA Device Query (Runtime API) version (CUDART static linking)

    Detected 1 CUDA Capable device(s)

    Device 0: "GeForce GTX 970M"
    CUDA Driver Version / Runtime Version 7.5 / 7.5
    CUDA Capability Major/Minor version number: 5.2
    Total amount of global memory: 3072 MBytes (3221094400 bytes)
    (10) Multiprocessors, (128) CUDA Cores/MP: 1280 CUDA Cores
    GPU Max Clock rate: 1038 MHz (1.04 GHz)
    Memory Clock rate: 2505 Mhz
    Memory Bus Width: 192-bit
    L2 Cache Size: 1572864 bytes
    Maximum Texture Dimension Size (x,y,z) 1D=(65536), 2D=(65536, 65536), 3D=(4096, 4096, 4096)
    Maximum Layered 1D Texture Size, (num) layers 1D=(16384), 2048 layers
    Maximum Layered 2D Texture Size, (num) layers 2D=(16384, 16384), 2048 layers
    Total amount of constant memory: 65536 bytes
    Total amount of shared memory per block: 49152 bytes
    Total number of registers available per block: 65536
    Warp size: 32
    Maximum number of threads per multiprocessor: 2048
    Maximum number of threads per block: 1024
    Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
    Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
    Maximum memory pitch: 2147483647 bytes
    Texture alignment: 512 bytes
    Concurrent copy and kernel execution: Yes with 2 copy engine(s)
    Run time limit on kernels: Yes
    Integrated GPU sharing Host Memory: No
    Support host page-locked memory mapping: Yes
    Alignment requirement for Surfaces: Yes
    Device has ECC support: Disabled
    Device supports Unified Addressing (UVA): Yes
    Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
    Compute Mode:
    < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

    deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 7.5, CUDA Runtime Version = 7.5, NumDevs = 1, Device0 = GeForce GTX 970M
    Result = PASS
    /NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery$

    But still have some occasional 'flickering'

    Going for a game of DOTO :D
     
  9. geoworldFreshAir868

    geoworldFreshAir868 New Member

    I suppose, I just need to get back into Linux (probably going for Exherbo as soon as I'm back 'in shape')
     
  10. [QUOTE = "_ ramsey_, bài: 121.157, Thành viên: 26.099"] Tôi tự hỏi nếu có ai ở đây đã cài đặt Linux trên một lưỡi mới. Từ những gì tôi đọc sau khi một số googling, những vấn đề chính liên quan đến các miếng đệm theo dõi, nhưng sau vài tháng người ta bắt đầu nhận được nó làm việc. Nếu ai đã có bất kỳ kinh nghiệm, tốt hay xấu với Linux trên một lưỡi 14 ", tôi muốn nghe họ :)[/ QUOTE]

    smiley your comments come from them so cute. please give me your link. thank you
     
  11. _ramsey_

    _ramsey_ Active Member

    It's a standard emoji on insider. Click the smiles button in the top toolbar, then click the Twemoji tab at the bottom of the editing box.:secret:
     
    shivalkira likes this.
  12. [QUOTE = "_ ramsey_, bài: 207.499, Thành viên: 26.099"] Đó là một biểu tượng cảm xúc tiêu chuẩn về nội bộ. Nhấp vào nút nụ cười trong thanh công cụ hàng đầu, sau đó nhấp vào tab Twemoji ở dưới cùng của hộp chỉnh sửa. :bí mật:[/ QUOTE]
    thank you very much. I'm a new member I have seen this one without clicking. now, thanks to you wonderful also very much beautiful toolbar.:lè lưỡi nháy mắt:
     
  13. geoworldFreshAir868

    geoworldFreshAir868 New Member

    For somebody as myself who always buys his laptops with en-US keyboards (cos all symbols are placed nice for right pinky when coding) but needs to write in both Danish and Spanish, I really missed Mac OS X 'ALT+a' in order to create an 'å' and 'ALT+n' in order to make a 'ñ'.

    I found out this was possible to do on the Ubuntu as well by just using binding the "non desired" CAPS-LOCK key as the CompositeKey:

    [​IMG]

    Still a bit to go on getting used to the keyboard after many years used to the Mac OS X but we are getting there :)

    Btw, anybody know how to turn of the Razer Symbol LED when the LID is closed? It's a bit annoying having to put on a piece of clothe at night :)
     
  14. FacedorkTV

    FacedorkTV Member

    i use Kali Linux on a blade... It works perfectly...
    But i don't recommend it. Razer itself doesn't support linux...
    So you can't use the razer synapse ect.
     
  15. Hmizer

    Hmizer New Member

    Any tips for getting suspend to work on 15.10?
    Most everything else works "out of the box" on my 2015 QHD+, but no suspend isn't acceptable.
     
  16. _ramsey_

    _ramsey_ Active Member

    That seems to be new in 15.10. I rarely suspend so I haven't noticed it, but I just closed my lid, the backlit logo stayed on and after opening the lid, I could not wake it with keyboard.
     
    eboltz likes this.
  17. Hmizer

    Hmizer New Member

    Yeah, would be great to have. I'm recently paralyzed (reckless driver hit me on my bike) so I do a lot of work in bed and am currently doing a full shutdown between tasks to make the battery last longer. Suspend would be great.

    Well now this is a bummer. I figured I'd give up living on the cutting edge with 15.10 and just install 14.04 LTS. By doing this I'd get access to the coveted "suspend" feature. Unfortunately, it appears - at least from the 14.04 Live image - that 14.04 has the same suspend error (screen goes black, keyboard stays illuminated, fans run, have to power off).

    I suppose I should go with Mint as their Live suspends properly.
     
    Last edited by a moderator: Aug 13, 2016
  18. buzzPinkdirect588

    buzzPinkdirect588 New Member

    It pains me to write this.
    I switched to Windows 10 after many months on the 14.04 LTS. What a shame! It would take few resources, to fix a few bugs and make Ubuntu available for Razer's user-base. It would help with retention for sure.

    @eboltz sorry for your accident, man!
     
  19. urbanBlacklab029

    urbanBlacklab029 New Member

    @brain.cards what couldn't you get working that got you to switch? I loaded the lasted x64 release without issues. When I did updates I kernel crashed on boot but without updates all the basics seem to be working.
     
  20. Hmizer

    Hmizer New Member

    Do you have suspend working?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >