Linux on a new blade

Discussion in 'Systems' started by _ramsey_, Feb 4, 2015.

Thread Status:
Not open for further replies.
  1. SuperEvenSteven

    SuperEvenSteven New Member

    Thanks dugfin, I was looking for a way to make acpi calls. I didn't know there was a kernel module fit for that purpose until now.

    I've updated my Ubuntu guide for Razer Blade 2014 with a section on how to fix the lid state.

    https://drive.google.com/open?id=1c2rrRvQk1LloSV_gw4I7WeKzonfd1k-Y2_nCCEYyX4I

    Cheers,

    Steve
     
  2. Her0Zer0

    Her0Zer0 Member

    One more useful command for disabling touchscreen to save battery:

    xinput disable "ELAN Touchscreen"

    Just replace "disable" with "enable" to turn it back on
     
  3. Makyura

    Makyura Member

    I'm still learning Ubuntu, so, sorry if this one is a dum question.

    How to make this happen directly at boot?

    Thanks
     
  4. rb6freak

    rb6freak New Member

    You can put that line in your rc.local file (typically /etc/init.d/rc.local).
     
  5. leafoflegend

    leafoflegend New Member

    Is anybody able to confirm that this suspend on lid close fix (above this reply) works for the 2016 Blade? Seems a little hairy to be making acpi calls. Having just seen it earlier in the thread too - my video camera on my computer works fine. I think the 4.7 kernel sorts that out.
     
  6. PapaSmurf6768

    PapaSmurf6768 New Member

    What steps did you follow to get Bumblebee working? I want to use it because it has better power saving than Prime, but from my testing there are still some issues with it. Mainly, GPU stays on while suspended.
    Would also love gesture support.
    This is on 2015 Blade 1080p version, 4.6.5 kernel, Ubuntu MATE 16.04
     
  7. Makyura

    Makyura Member

    Hello, looks like that once you install Nvidia you need to go through alot of troubles to get Bumblebee working, I don't even recall how I did that the first time (google helped me tho), what I know is that it's much easier just installing Bumblebee (UEFI off) once you get into your fresh install, before installing Nvidia drivers.

    Once that's done, just install Nvidia drivers after one reboot and everything will work like a charm.

    I've had alot of problems while I tried to do this through a different way, so I know your feel.

    Looks like gesture support is far from being available, I've spent a day trying to achieve it, but I had to give up on that (reason why I keep using W10 for most of my daily routine stuff).

    I'm on a RB 2015 QHD version.
     
  8. PapaSmurf6768

    PapaSmurf6768 New Member

    OK, think I have everything working now (besides gestures) on my 2015 Blade 1080p. Will outline my steps here if it helps anyone.
    1. Install Ubuntu 16.04 from live USB (I have the MATE version)
    2. Install 4.7 kernel from Ubuntu mainline: http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.7/
    3. Add ppa's: ppa:graphics-drivers/ppa and ppa:bumblebee/testing and update.
    I had problems with bumblebee until I installed the developer version from that repository
    4. Install nvidia and bumblebee using a combination of these two guides
    http://lenovolinux.blogspot.com.au/2016/05/bumblebee-on-lenovo-t440p-nvidia-gt.html
    https://rajat-osgyan.blogspot.com/2016/04/how-to-install-latest-nvidia-drivers-on.html
    Mostly the second, but there's some good info in the first. I used the latest bumblebee package from the "testing" ppa and nvidia-367 from the graphics-drivers ppa

    I think that's all I did.
    Suspend working, graphics switching working (with the primusrun command), battery life on par with Windows.
    I didn't want to use Prime because it's inconvenient to log out and back in, plus it doesn't actually turn off the Nvidia card like Bumblebee does. You won't get as good battery on Prime.
    Any questions let me know, I've been fighting with this and researching for days.

    Got gesture support working too using TouchEgg :)
    Might only work on MATE, but it's flawless for me. See here.
    http://askubuntu.com/questions/789915/ubuntu-16-04-multitouch-gestures
    Looks like I'm all done fiddling.. Sad because I like fiddling. But now everything is perfect. Bye Windows!
     
    Last edited by a moderator: Aug 13, 2016
  9. Her0Zer0

    Her0Zer0 Member

    I made the mistake of missing the part where you said it was a 2015 Blade, so I went and tried this once again on my 2016 Blade. And once again, it totally borked my entire install - like graphics completely hosed. I'm very familiar with Ubuntu and after 5 days of trying to restore, I finally gave up and went with a reinstall. I give up on Bumblebee forever - I'm pretty sure there's something in that repo which completely screws up X and cannot be repaired. I saw logs showing failed driver attempts trying to connect to Mir - which makes no sense as I'm using unity but that's exactly the sort of deep rooted bug that I prefer to avoid at all costs. Thankfully, I didn't have any lost data.

    On the plus side, the latest image of Ubuntu 16.04 seems to have gotten the backport of the necessary fixes for keyboard, touchpad and even wifi drivers with default install. This makes is a lot better. The nouveau display drivers also work on first boot which is good as well. However, I prefer the higher performance proprietary drivers, so I removed those and reinstalled the nvidia-367 drivers along with prime and prime indicator and everything actually seems to be working much better than before (I also installed the intel micro code proprietary drivers) . I'm sticking with the ubuntu 4.4 kernel as it has all the things I need now and likely is more stable than mainline.

    One thing that's really important: you NEED to stop the lightdm service before installing the nvidia drivers. It just doesn't work well or at all otherwise. This includes any updates that you get through apt. Unfortunately, that means you need to drop to the terminal with its microscoping font, manually stop the lightdm service and then do the update/install - and finally reboot. But this seems to work best.

    I also recommend the prime-indicator app for Unity which makes switching between Intel and Nvidia easy enough. It's not ideal, but it works consistently with the desired performance. And if you use VLC, I also recommend getting version 3, which means you'll need to add the master repo to get it.

    Suspend on lid still doesnt work unfortunately, but I have yet to try the recommendation further up this thread and prefer to have the current stability vs. messing with mainline.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >