Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

My 5% discount code went poof!

Discussion in 'General Discussion' started by Artrexo, Jan 18, 2017.

Thread Status:
Not open for further replies.
  1. Artrexo

    Artrexo New Member

    (NOT CES code)

    I'll try n keep her short!
    So I tried purchasing the RBS yesterday and today however I keep getting the payment authorization failed message. I contacted bank and they rose my limits and whatnot and Razer customer support is taking their sweet time with replies (eh, no worries :heart:)

    I tried purchasing the stealth via paypal with a 5%off coupon (which customer support had bestowed upon me earlier for bringing a website bug which had inconvenienced me to their attention) however upon receiving the disappointing message of payment authorization failed, my discount code has also been made unusable (even though I didn't use it...)

    Anyone know how I can get this sorted out? I was recalling looking forward to purchasing a stealth and the 5% discount code was my ticket to a neoprene sleeve. I can't use the student discount because I'm not yet in uni and Canada doesn't have Edu emails as far as I know.. (Or better yet, want to buy the stealth/blade for me? ;) )
     
  2. Jaisani

    Jaisani Cat

    Hi @Artrexo I have contacted you directly to assist you further. :)

    Also to anyone else facing similar issues, please do contact our Support Team and do feel free to contact me directly if you guys require any further assistance.

    I'll be locking this thread now. Just a friendly reminder, Razer Insider is not a support forum.
     
    Last edited: Jan 18, 2017
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >