Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

Razer Synapse 2.20 not changing sensitivity for DeathAdder Elite

Discussion in 'Mice and Surfaces' started by Isaiahmag, Mar 22, 2017.

?

Is anyone else having this sort of issue?

  1. Yes

    4 vote(s)
    50.0%
  2. No

    4 vote(s)
    50.0%
Thread Status:
Not open for further replies.
  1. Isaiahmag

    Isaiahmag New Member

    I am currently using Windows 10 and for some reason one day my mouse has not wanted to change it's sensitivity and eventually I tried uninstalling it and it somewhat worked. So I can get the sensitivity to change but it doesn't have my specific settings that I have on Razer Synapse. Also it's not just the sensitivity it's all my settings on Razer Synapse. If there is a way for me to revert back some versions of Razer Synapse I'd like to know to see if that would fix this issue.

    Just so you know I have tried uninstalling/reinstalling Razer Synapse twice along with restarting twice.
    Oh and I tried uninstalling the mouse and I think I may have uninstalled the devices software...
    [​IMG]
    Now I really need help.
     
    Last edited: Mar 22, 2017
  2. smiley-face002

    smiley-face002 Active Member

    Normally the drivers for a mouse where installed automaticly by windows. But in you picture windows is seening the mouse as a keyboard
     
  3. ETitus

    ETitus Active Member

    It works fine for me in synapse. Just tested it for you. Did you try a different USB port?
    Perhaps you should contact support. I guess they will be able to help you better!
     
  4. Isaiahmag

    Isaiahmag New Member

    The reason why the mouse registers as a keyboard is most likely because the extra buttons but besides that I may have uninstalled the mouse driver by accident but I am not completely sure.
    I have attempted to plug the mouse into another port but as soon as I open Razer Synapse I get this.
    [​IMG]
    I guess I'll be attempting to contact Razer Support but before they didn't even really help me with my capture card issue and it seemed like it was just a bot I was talking to so I thought maybe it'd be best to make a thread.
     
    S0dap0p likes this.
  5. ItzHaZe

    ItzHaZe New Member

    I have this same problem but I have found a solution on youtube:


    It says you need to disable the razer stats which I am going to do on Saturday so I will try to reply to see if it works. Razer's recent update added the stats and heatmaps and it affects your dpi for some reason.

    I have been testing my mouse for the past 2 days and this video has resolved the problem so hope this helps you out!
     
    Last edited by a moderator: Jun 3, 2017
  6. Hey man,

    I just made up my own thread but it got closed.
    So i was scrolling through all the mouse problems and saw your problem. I fixed this problem by just installing Razer Synapse again and for my personal preference i disabled the stats and heatmaps. That seemed to fix my DPI change bug.
    So after i scrolled a bit further down i saw you are stuck on the page after the logging in page. I have never had any problem with Synapse and im currently having the same issue. I haven't found a fix yet but after some looking to the drivers of the mouse i was sure it has to be something with the USB-ports or Synapse itself.
    I have allready mailed Razer by using their Razer Support site but haven't got any response just yet.

    If i get to know anything about this problem i'll let you guys know.

    (btw i know there was a fix for it a year ago but that doesn't fix this problem.)
     
  7. Marinenukem

    Marinenukem New Member

    I would disable stats and heatmaps, but I can't even find them, I've seen pictures and its supposed to be a tab next to the Micros tab, but its not there. Pls help!
     
  8. TheMajinTrunks

    TheMajinTrunks New Member

    Found the fix!

    1. Find a alternative mouse to make this easier.
    2. Remove Deathadder Ellite from Device Manager by uninstalling the device
    3. Turn Off Synapse.
    4. Download the Firmware updater for Deathadder ellite
    http://dl.razerzone.com/drivers/Synapse2/win/Razer_Synapse_Framework_V2.21.00.712.exe
    4. Uninstall Synapse
    5. MAKE the updated Deathadder is disconected from your PC now.
    6. Reinstall Synapse.
    7. Update Synapse.
    8. After Synapse stops asking for updates, reconnect your Deathadder.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >