Synapse 3 agreement loop

Discussion in 'Razer Synapse 3 Beta' started by machusetas, Sep 1, 2018.

Thread Status:
Not open for further replies.
  1. machusetas

    machusetas New Member

    Everytime I try to login on Razer Synapse 3 the agreement policy popups, I accept it and then it redirects me to login screen again, where I have to accept the agreement policy again, that on loop.
    I reinstalled it, removing all residual files, installing and starting it as Administrator, removing the "read-only" Windows permissions on Razer folders and subfolders... still not working.
    Someone knows how to solve it?

    Another post of someone with same problem: https://insider.razer.com/index.php?threads/synapse-3-stuck-in-agreement-loop.40995
     
  2. machusetas

    machusetas New Member

    Finally found a "solution".
    I tried to login with my account on another computer, it still gave the problem.
    Then I tried to login on that computer with another new created account and it worked.
    Today I loged with the new account on my computer and it worked.
    So the problem seems to be related with old accounts...
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >