Ubuntu 20 setup & display flickering (Blade 15" 2021 FHD)

Discussion in 'The Linux Corner' started by gilettetheb, May 3, 2021.

  1. gilettetheb

    gilettetheb New Member

    Here's my Razer Blade 15" (2021) FHD setup notes for Ubuntu 20.4 so far - https://gist.github.com/cachvico/03b6e37c8907e277dafc6c6183a732d5

    It achieves the following:
    • Gets wifi working
    • Disables Bluetooth as I couldn't get it to work
    • Fixes resume after lid close
    Apart from Bluetooth, the only remaining problem I couldn't fix is that the entire display appears to jump up and down by a single pixel every few minutes or so. This happens even in console mode, no X11 involved. But not in Windows, so definitely not a hardware fault.

    Any ideas about any of this would be greatly appreciated!
     
  2. buzzingelephant

    buzzingelephant New Member

    Did you manage to find a solution?
     
  3. AMBERRuberdirect415

    AMBERRuberdirect415 New Member

    Hello, I meet the same problem as you said in the above! Have you solved the screen dispaly problem? If you solved it, can you tell me how to do it? Thank you, very much!
     
  4. gilettetheb

    gilettetheb New Member

  5. gilettetheb

    gilettetheb New Member

  6. IVORYrushShampoo824

    IVORYrushShampoo824 New Member

    Got exactly the same problem, waiting for some answers.
     
  7. IVORYrushShampoo824

    IVORYrushShampoo824 New Member

    OK, I think I fixed the flickering problem (for now), here is what I did:
    The key is to use the latest kernel (12.10)

    1. After installing Ubuntu 20.04.2 LTS, you have to use a USB to transfer the kernel 11.0 since you won't have internet after installing the Ubuntu and install it using dpkg -i *.deb (remember to download all four kernel files). Reboot (remember to disable the secure boot in BIOS, otherwise it won't let you use the kernel 11.0) and now you have internet!

    2 the next step is to update kernel to the latest 12.10. You won't be able to install it using the same way to install kernel 11.0 because the dependency problem (it requires libc2. 33) , so the work abound is using tuxlnavder's ppa:

    sudo add-apt-repository ppa:tuxinvader/lts-mainline

    sudo apt install linux-image-unsigned-5.12.10-051210-generic linux-modules-5.12.10-051210-generic linux-headers-5.12.10-051210-generic

    And Rboot.


    So far so ggod, no flickering and no keep going to sleeping mode. I figured that kernel 10 doesn't work, and kernel 11 has the flickering problem, and not fully installed kernel 12 gives you random sleeping mode. It will still give you some API errors when you boot, but I will ingore it for now... I installed drive 460 and cuda 11. Let's see how it goes, fingers crossed.


    Razer blade 15 configuration:
    i7 8core
    RTX3070
     
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >