Synapse 3 and Mamba Wireless mouse

Discussion in 'Razer Synapse' started by manuman_the_man, Nov 1, 2018.

Thread Status:
Not open for further replies.
  1. manuman_the_man

    manuman_the_man New Member

    Hi! All those we have Razer Mamba Wireless know that Mamba wasn't compatible with Synapse 3. So we started using Synapse 2 in order to configure it. Plus, I have the blackwidow keyboard and I have Synapse 3 too (yes, two Razer Synapse versions at the same time).

    Today Synapse 3 is updating with amazing news: Mamba Wireless is compatible with Synapse 3.

    So what's the problem? The mouse is not being recognized by the software. I uninstalled the V2 and uninstalled the mouse drivers in the windows device manager without luck.

    What do I have to do to make Synapse 3 recognize my mouse?

    Thank you, greetings.
     
  2. BlackFireDragon

    BlackFireDragon Well-Known Member

    Uninstall all razer softwere then delete files that stay on your pc and reboot when pc start install only synapse 3 and cheack if the mouse is on device list in synapse. Remember about hidden folders every file contain data and synapse after install backup it. You need clean install :stuck_out_tongue_winking_eye:
     
    Loxodon13 and manuman_the_man like this.
  3. manuman_the_man

    manuman_the_man New Member

    I've already tried to do it, but I don't get it working. I have uninstalled all Razer, then rebooted windows, then uninstalled the mouse at the device manager and finally installed Synapse with the latest installable (from the original web page).
    I don't know how to continue now :frown_:
     
  4. BlackFireDragon

    BlackFireDragon Well-Known Member

    Ok but you delete files after uninstall from program files and appdata folders ? If you do it and still you have detect issue you can try to remove from windows device manager and unplug mouse reboot and connect one more time windows will detect new device and install new drivers. You can also try to connect mouse to other pc if you have one to make sure everytning is a softwere issue related to synapse not a mouse it self.
     
  5. shafiqepain

    shafiqepain New Member

    My guess is that you have the old Razer Mamba (2015). The support added is for the new Razer Mamba Wireless. But let us know if it worked for you so I can start using Synapse 3.
     
    manuman_the_man likes this.
  6. manuman_the_man

    manuman_the_man New Member

    No, I couldn't get it working with Synapse 3. I bought the most expensive Razer mouse and it's not compatible with the latest software... So bad
     
    VocableLyric60 and Andrewxy3 like this.
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >