Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Update] Razer Synapse and macOS Sierra

Discussion in 'General Discussion' started by Razer.WolfPack, Sep 7, 2016.

Thread Status:
Not open for further replies.
  1. Received multiple e-mails from Razer. But this time is true. They FIXED IT!

     
  2. Dude, I do hope that Karma hits you hard for defending Razer like it seems you are an employee or relative or something like that.... everyone is having the same issues:

    - Trackpad slowed when connecting a Razer mouse
    - Sticky keys... need to press ESC in game to solve it and happens often.
    - At some point the keyboard starts having delays
    - The DPI change just goes nuts and adjusts whatever value it seems to think of
    - Still incomplete software compared to windows
     
  3. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Soooo, me answering your question and saying that I haven't had the same issues that you've had is defending Razer? That doesn't make any sense at all. The post that you quoted doesn't defend Razer at all. It simply answers your question. Nobody else had answered it, so I thought I'd help and do so. Then I get told that I am doing something bad? WTactualF?

    Plus Karma hitting me for defending Razer . . . actually sounds like a good thing. I think it worked PROactively (because all I did was answer a question, and not defend Razer): I got into the CES Appreciation event without a hitch and was able to get exactly what I wanted.
     
  4. This is not the only time you do this... keep being delusional if that makes you happy.
     
  5. UPDATE: Tested the latest version and still the trackpad is slow when the mouse is connected. Will report later if the sticking keys are still there.
     
  6. Random3

    Random3 New Member

    As luck would have it, the day Razer (apparently) fix the problem is the day I get my gaming PC up and running...

    I am curious to see if it has actually been fixed, but I won't be using my Razer peripherals on my Mac again.
     
  7. Guapz

    Guapz New Member

    First of all, thank you Razer for bringing out this update, it fixes a lot of issues people were experiencing.

    I am happy to see that the sticky key thing is partially fixed, I only experience it with macro's right now (for example i have a Ctrl+6 macro, and the Ctrl does not release). So that is still something you might want to take a look at. But the fact that the normal use of the Ctrl key, shift key and Alt key is fixed helps a lot!

    Hope you keep bringing out updates that improve the experience of razer synapse on mac!
     
    Damiancito likes this.
  8. directhitBone895

    directhitBone895 New Member

    Still the same modifier problems here in combination with Naga mouse.
    So basically the Naga mouse thumb buttons don't work in combination with Modifier keys.
    When i press at keyboard Alt or Shift + Naga 1-9 the stroke is registered as just 1-9
    like i did not press the modifier.

    Anyone else is still having this. 4 months trouble now.
     
  9. Random3

    Random3 New Member

    Ok I can't quite believe this.

    New computer running Windows 10. Make a macro on my Orbweaver to alt+tab between different pages.

    Same. Fucking. Bug.

    I am going to sell my Razer gear and get Corsair.
     
  10. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Is this a new Mac running Bootcamp, or a Windows-native PC? Have you contacted Razer Support about this issue?

    Also, in a previous post you mentioned you're running Yosemite on your Mac. Was there a Synapse version that worked fine for you? Or do you remember WHICH update messed things up?
     
  11. Random3

    Random3 New Member

    No this is a brand new PC build I did two days ago. Moved my Naga and Orbweaver from my Mac to my new PC because their hardware doesn't do what it is supposed to do on Mac. If this new patch has fixed the problem on Mac, great. But the fact that the first macro I make falls flat on it's face makes me seriously doubt that it has. Also there seems to be a bug where some of my profiles don't save, so I have to re-map my keys.
     
  12. PT.Singer

    PT.Singer Jedi Master VANGUARD

    I'd definitely contact support about it, or submit a bug report via Synapse.

    FYI, any new patches that fix things on Synapse for Mac have NOTHING to do with problems with Synapse on Windows. They are 2 completely different pieces of software - patches on the Mac side will only fix Mac problems or update things there; patches on the Windows side don't touch Mac problems at all.
     
  13. Random3

    Random3 New Member

    I might, thing is I am in the market for a gaming keyboard and I have had no end of problems with Synapse and the Orbweaver. This Naga Epic has worked fantastically since day one, but then I haven't used it for any macros. My old Naga died after 2 years. Even if they do fix this problem I think it's time for a change.
     
  14. PT.Singer

    PT.Singer Jedi Master VANGUARD

    That's sad to hear (just from the point of view of a Razer fan). I'm going to boot into Bootcamp and try to see if I can get an alt-tab thing going, and maybe help you out there. I don't have an Orbweaver, but I do have a Naga Epic and a Tartarus.

    Edit**
    I'm going to PM you about my findings.
     
    Last edited: Jan 19, 2017
  15. Random3

    Random3 New Member

    Just did a bug report.

    If they fix this then I will likely go with a Razer keyboard. Fact is, the Naga is fantastic, and if the software worked properly I would use the Orbweaver a lot more often. I actually like the Synapse software when it works, but the amount of problems with it is ridiculous. I don't want to sell my Naga and Orbweaver and go with a different brand but if this doesn't get sorted I see no alternative. I can't give Razer money for a keyboard if their software means I can't use the functions it advertises.
     
  16. uptechnoMustard760

    uptechnoMustard760 New Member

    Hi,
    I have an annoying issue related to Synapse (I think). I buy a new Orochi mouse 2015 model and I observe after a few minutes my trackpad is very slow when I use it ( I have Macbook Pro - Sierra 10.12.2 version ). To fix this problem everytime I need to go at System Preference - Trackpad and select a lower or higher value at tracking speed option but after if I use again Orochi the problem appear again and I need to do this process everytime when I want to use trackpad.
    I hope Razer will fix quickly this issue because is not OK.
     
  17. I think I'm still having some issues, like Media keys not working without Fn, opening the Synapse app solves it.

    And as before randomly getting multiple keystrokes and some strange behaviour.
     
  18. PastelGraybitfun056

    PastelGraybitfun056 New Member

    Hi

    With Synapse 1.66.9 on Mac OS X Sierra 10.12.3 and the Razer Mamba TE mice, the settings of buttons (4), (5), (8) and (9) are not permanently maintained.

    The configuration of these buttons is changed to the original configuration after opening and closing Synapse a couple of times. This bug also occurs when rebooting the system.

    Apparently the rest of the configuration is saved correctly.

    Until the bug is solved, what I do is export the configuration immediately after making the changes I need and when the problem occurs, I import the previously saved configuration.

    I hope it is resolved soon, the quality of the mice deserves it.

    Thank you Razer.

    [Update 20170204 10:54am] Another Workarround until the bug is resolved. I purchased a license of the cheap application BetterTouchTool 2.02 https://www.boastr.net and with a simple configuration you can get the key combination for the buttons that fail (attachment screen shot of the app)

    [​IMG]

    [​IMG]
     

    Attached Files:

    Last edited: Feb 4, 2017
    PT.Singer likes this.
  19. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Thanks for the workaround! And welcome to Razer Insider!
     
  20. I think I tracked the problem, is again about the modifier keys being swapped... If I close one tab with CMD+W, sometimes the W key got stuck, in the pick below you can see how hovering the mouse over any letter goes immediately to the Wacom option.
    I had this behaviour before with C, W, V T, numbers so The problem is here.
    [​IMG]
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >