Flashing newer BIOS Version

Discussion in 'The Linux Corner' started by Lugesch, Mar 4, 2017.

Thread Status:
Not open for further replies.
  1. Lugesch

    Lugesch New Member

    Hey guys,

    I just found out that there is a new BIOS-Version for the Razer Blade Stealth late 2016 edition, that removes the coil whine.
    So I went to the Razer Blade FAQ and found a download for Windows but not for any other OS.
    I am only running Arch Linux on my System no dualboot or anything else.
    I found a guide to flash the bios under Arch in the Arch Wiki but I still need the bios.
    Does anyone know where to get the new bios, so that i can flash it via linux or did any of you guys already flash there bios under linux ?

    Thanks in advance :)
     
    AresMinos likes this.
  2. Kingkylest

    Kingkylest New Member

    Also interested in updating my BIOS on Arch. Anyone do this successfully?
     
  3. Hello,
    There's a 8.4Mb file named H2_6_05_0126.bin inside the archive. You can perhaps risk to use it, but you have chances to transform your RBS into a beautiful black brick instead
     
  4. owxpr_no_id

    owxpr_no_id New Member

    Last edited by a moderator: Mar 27, 2017
  5. Lugesch

    Lugesch New Member

    I dont know if i should risk it.
    I will try and get a dualboot windows running and install the patch using that.
     
  6. PlatinumC

    PlatinumC Active Member

    I am 90% sure that the bios file itself is not OS dependant, however, the soft/hardware companies sometimes provide their own bios flash tools, that may be for a specific OS, or a flash method.
    But if you know what you are doing, you should be able to use the above mentioned bin file manually.
     
  7. Kingkylest

    Kingkylest New Member

    Still waiting for an update... Has anyone done this successfully? Min claims they're going to 'support' Linux but now I can't even reboot or shut down properly v_v
     
  8. Kingkylest

    Kingkylest New Member

    Too afraid of bricking my device Minh has ignored my message so idk...
     
  9. I've flashed my bios from linux on the first gen razer blade stealth (6500U), but not from a razer provided bin file. I actually read my own bios image and modified visibility of thunderbolt stuff so I could get the core working in linux. But it was uh, I guess I'd say I can't really recommend it. I have no idea if it'd even work on the razer provided .bin files.

    But just in case you are interested in bricking your rbs, here's what I did: search for afulnx64, the wmibios link is broken (hah!) so go to the domoticx one (yes, who knows...).

    This will download something that will fail with compile errors. You need to use strace to extract, fix and compile the code manually (yes, really). It's actually a simple small change:
    https://blog.fastmail.com/2016/05/09/updating-supermicro-bios/

    I had to change some steps he did, but afterwards I was able to extract my own bios image, modify that .rom file and then flash my own bios from linux. Essentially my changes were just:
    mv amifldrv_mod.ko amifldrv_mod.o
    in the Makefile and then sudo ./afulnx_64 worked for me
     
  10. HypocriticalIdiot

    HypocriticalIdiot Active Member

    BIOS updates are always nice
     
  11. Kingkylest

    Kingkylest New Member

    Hey Everybody. If you cannot shutdown, suspend, or hibernate without encountering fatal inhibiting errors (RBS 2016) try downgrading your kernel/headers and modules. I went from Arch 4.10.4 to 4.9.9 and now everything is going swimmingly!

    add 'linux linux-headers linux-api-headers' to IgnorePkg in order to make sure you don't update again. I am quite new so please don't take my advice unless this makes sense to you, you are comfortable doing this, and you are experiencing similar issues to the ones I have been experiencing.

    All the best.
    (Still no news on BIOS update afaik. We're all alone.)
     
    Last edited: Mar 22, 2017
  12. You can also use linux-lts instead of linux, it's still on 4.9 on Arch for now.
     
  13. I was able to update the BIOS on my 2016 razer blade stealth from the H2_6_05_0126.bin image in the BIOS update utility found at http://www.razersupport.com/gaming-systems/razer-blade-stealth/

    To get the image run these commands in terminal then flash the H2_6_05_0126.bin file that is extracted

    curl -O http://dl.razerzone.com/support/BladeStealthH2/BladeStealthUpdater_v1.0.5.3_BIOS6.05.exe.7z
    7z e BladeStealthUpdater_v1.0.5.3_BIOS6.05.exe.7z
    7z e BladeStealthUpdater_v1.0.5.3_BIOS6.05.exe

    The coil whine isn't there anymore.
     
    Last edited: Mar 26, 2017
  14. Ryan: What did you use to flash the image?
     
  15. Weird, when I was trying freedos with CMS enabled I was just getting junk video output and freedos wouldn't come up. The same USB stick was working fine in a VM.
     
  16. Jean Claude_no_id

    Jean Claude_no_id New Member

  17. Kingkylest

    Kingkylest New Member

    Are you using Linux? If so, what utility?
     
  18. Kingkylest

    Kingkylest New Member

    For the Razer Blade 14, not the stealth.

    Are you using this fix on the RBS Late 2016?
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >