Razer Core/Blade Stealth Problem

Discussion in 'Systems' started by Kosta_454, Sep 23, 2016.

Thread Status:
Not open for further replies.
  1. Kosta92

    Kosta92 New Member

    Hey guys,

    I just received my GPU for my razer core to razer blade stealth connectivity and when I plugged it in I installed all the drivers as they appeared and the intel drivers. It was working fine up until all of a sudden my laptop would flash and disconnect from the core and the Desktop monitor connected to the core would turn black and wouldn't reconnect. Then a few moments later it would randomly connect again. It would keep doing this at random times and now I tried it this morning and doesn't want to connect at all but you would still here the clicking noise and the chroma lights would appear for a few seconds sometimes then shut right off but most of the time the lights won't even turn on. A couple times when it would disconnect and reconnect again, my screen would turn baby blue with white letters and a :slightly_sad: (sad face) in the top left corner of my screen would appear saying "There is a problem with your PC, a restart is needed, sending information and will restart when finished" and it would have the percentage right underneath and then it would restart when reaches 100%. It has done this about 3 times already (this is before this morning when it wouldn't connect at all).

    Any suggestions?? I read on the other thread about the wifi and Ethernet issue so I will try that as soon as I can which is sunday (Sept. 25).

    Any help would be appreciated thank you
     
  2. Eason85_no_id

    Eason85_no_id Member

    The core seems to have a defect with the magnet in it. The magnet connection is poor and thus it's losing the connection. This is common.


     
  3. AloysiusTee

    AloysiusTee Member

    Contact razer support about it and see what they say about it. You should not be facing all these problems when you pay a premium for a product like this
     
  4. Dylan_Ma

    Dylan_Ma Member Staff Member

    Hi @Kosta_454, have you tried contacting Razer Support? They will be able to assist you with this issue.

    I'll be locking this thread, if you require any further assistance, do feel free to contact me directly.

    Do note that Razer Insider is not a support forum.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >