Dismiss Notice
Some Razer services have been impacted due to the unique circumstances COVID-19 has created. We apologize for any inconvenience and appreciate your understanding during this critical time.

[Update] Razer Synapse and macOS Sierra

Discussion in 'General Discussion' started by Razer.WolfPack, Sep 7, 2016.

Thread Status:
Not open for further replies.
  1. Is there any way to block @PTSinger replies on the threads? I don't mean for everyone.. just for my own sake.
     
  2. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Yep. Click on my name on the left. You'll see an option for "Ignore". Anything that I write will come up for you as "Ignored Member" and you won't see anything that I've written.

    That's how your comments show up for me. I actually have to click on "See Ignored Messages" in order to see anything that you've written . . . anywhere on this forum, @Damiancito. It works.

    Glad to help!

    But in all seriousness, if you want to go deeper than that, then you'll have to direct your responses. Maybe @Razer|Jaisani_Choe can help you more than I was able to here.
     
    Damiancito likes this.
  3. So I've scrolled through most of this thread, but can't seem to find an answer about the scroll wheel. Is there any way to increase the scroll wheel speed (or number of lines per scroll) when using apps like a web browser, for instance?

    This is my first Razer mouse and keyboard, and the scroll wheel issue is driving me crazy, as I find it too slow for my liking. I have the Razer Mamba TE, fwiw.

    Thanks in advance for any input.
     
    TrueEddie likes this.
  4. Hi All!

    I found the solution and it costed me 60 EUR. I was in France a few days ago and saw the Sensei RAW which is COMPATIBLE with MAC, I didn't see the point for the more expensive SteelSeries just to try.

    Uninstalled Synapse, plugged in the mouse, got their software installed, it updated the mouse firmware and voilá. Restarted and I still have a functional Razer Keyboard (no macros or anything just normal stuff) and no more Razer Mouse. I got a lot of acceleration so I downloaded their tool for that, again problem solved.

    Played a match of LOL, dear God.. no more freezes, no more skipping, no more mouse coming to the middle of the screen for no reason.. my A and P keys were working bad inside the game now they work as they should.

    So, I have 2 Razer mice that I'm not able to use properly + a keyboard without special functions (all that for a lot of money, way more than Sensei products).

    Then for THOSE (OR THAT ONE) that insist that Razer is a small company so that's why they cannot make a proper mac implementation, just look at SENSEI and tell me they are bigger.. please do!

    I'm still utterly disappointed at Razer for making a more utterly annoying experience than it should, so to all of you looking for a solution it's sadly to buy another product. I feels sorry for the money you have spent as I tried getting a refund and couldn't. The experience with support was even more annoying, with people giving me instructions for windows when I stated I was on mac.

    I'll still keep them just in case I get to have a windows machine but again, with great sorrow I hope you, SMALL COMPANY guys, get into your senses and understand that you need to deliver quality software as well, I'm not paying pennies for your peripherals, I paid one of the most expensive brands there are as I always thought that was the way to get more fun out of my gaming hours.

    Hope one day a proper software comes out.
     
  5. Any word when a native / compatible version of Synapse will come out for macOS Sierra 10.12.x? The current version, 1.68.20, works but is pretty buggy. And good luck clicking the icon in the menubar by the clock without it freezing.
     
  6. PT.Singer

    PT.Singer Jedi Master VANGUARD

    I haven't checked it out yet, but there is a 1.69.xx that is available for download. I couldn't find it on the Synapse page, and it's not available with the "Download" button there, but since I like to have complete downloads of each version, just in case I have to revert, I needed to find the update.

    So this is the link.
     
  7. derrick7

    derrick7 New Member

    I saw on the app that there was an update. 1.69. and they mentioned in the change log that is it ready for new product. I am not confident about the update and afraid that my keyboard and mouse will be worst than it is now hence I did not download it.
     
  8. Do we still not have a proper resolution for Synapse and MacOS Sierra?
     
  9. PT.Singer

    PT.Singer Jedi Master VANGUARD

    I've been spending a LOT of time in Bootcamp (with the Paid to Play stuff happening and some other things involving Razer Cortex which still doesn't work with Mac OS . . . yet), so I haven't had time to really mess around with the update and my Razer gear. Other than the scroll still being slow (one click up/down per click on the mouse wheel), I haven't noticed anything different. I'll definitely let the community know what hassles I have once I get around to testing all my gear in Sierra.
     
    derrick7 likes this.
  10. derrick7

    derrick7 New Member

    Thanks for the info. I have updated the app last weekend. I am happy to say that my Man O War is working now. Previously I cannot install it as i need to use the older version app to have my mouse and keyboard working. Currently my mouse no longer have the double click issue. Thats one thing that I am happy about the update.
     
    PT.Singer likes this.
  11. Mainman99

    Mainman99 New Member

    Got prompted to update my Razer Synapse and 1.70.4 is now installed.
    Fixed the 2 problems I had with my Razer Naga Chroma (profile didn't swap when I switched application and I can now change my lightning settings).
     
  12. Enroth

    Enroth New Member

    I have a question - Like many people here, my modifiers are not working (presumably following the Sierra update for my mac?)

    I've tried a few things - visiting https://www.razerzone.com/synapse/ to update my software and using the script (
    defaults write com.blizzard.worldofwarcraft disable-expose-fix YES)
    for terminal.

    The above did not resolve my modifier issues (that I do not have on my windows pc, by the way).

    One thing that struck me as odd though, is that the software for mac reads as if the version is 1.42 on the website (as shown in the photo below).

    Why is that?

    I checked on the synapse software on my computer (that I reinstalled just now) and it says my software is up to date.
    Screen Shot 2017-05-13 at 16.44.53.png

    [​IMG]
     
  13. tadaam

    tadaam New Member

    Today i bought one Mamba 2012 and while on MacOS Sierra, the Mamba2012Migrator stopped responding while trying to update the mouse in Synapse 2.0. So i thought of a fix to bypass the "updating and leveling up Razer mamba".

    The fix i found: Install Synapse on a pc with windows (i had win7) and update anything there. Once you see the menu you can leave the pc and plug the mouse back to your mac. Everything should be working now. At least on my side i discovered the migrator having some long thoughts and bypassing with windows help made everything work normal.
     
  14. coveTeaGreenhead341

    coveTeaGreenhead341 New Member

    The glitch that causes RZupdates or RZengine to steal the focus every 2 seconds is still present. I've had to restart and waste time at work. If this doesn't go away after an uninstall and reinstall of synapse, I'll be tossing all my Razer products in the trash. Tired of this garbage forced software that doesn't work. Try hiring some people that can actually code.
     
  15. PT.Singer

    PT.Singer Jedi Master VANGUARD

    Hey @jtboik, is this something that has gone away for you with certain Synapse updates, or is it doing it again with the latest update? It happened to me for a little bit, and then it stopped and hasn't happened for months. I haven't updated to the newest version of Synapse for Mac yet, so that's why I'm asking.
     
  16. coveTeaGreenhead341

    coveTeaGreenhead341 New Member

    It has only happened after I just "updated" a few days ago. It only seems to happen when I don't have the mouse (deathadder) plugged in, as if it's freaking out that I would dare unplug my mouse and not take it to work with me.
     
  17. todayquickNyanza314

    todayquickNyanza314 New Member

    I've bought BlackWidow Tournament keyboard, installed Synapse, and found a lot of bugs. Nobody is wonder I think. FYI: I use macos.

    1. Fn+F10 doesn't switch on/off game mode, it just disables Win key, which I remapped to modifier key already.
    2. I cannot switch volume up/down, mute, etc. to be regular F1, F2, etc. keys. The only way to make F-keys work is to enable game mode, which disables Win key, which I use as modifier.
    3. Macros recording doesn't work
    4. Fn key doesn't produce any key code, which makes impossible to remap Fn+Fx keys... wtf?

    The software seems to buggy, uninstall for now and wait for the next releases.
     
  18. coveTeaGreenhead341

    coveTeaGreenhead341 New Member

    Yea that doesn't work for the mice, they'll fly around at 10 million sensitivity with no software, at least the old ones do
     
  19. I have been trying to get both my Kraken and Man O'War headsets to work on my iMac for weeks. I've gone between El Capitan and Sierra, tried almost every version of Synapse, and installed/uninstalled more times than I can count.

    The problem is that neither headset plays sound. Calibration, Chrome, Safari, iTunes, nada. When I go into System Preferences > Sound > Sound Effects, though, the system sound effects (pings, bleeps, boops) play perfectly in the headset. If I run the calibration, then switch to internal speakers, the calibration sound is there, so I know there's a signal.

    My thought is that there has to be some kind of hidden process that's overshadowing sound playback from applications ONLY through the Razer headsets, but it's getting very frustrating since Google is completely unhelpful, and Razer support just keeps escalating the issue without actually answering my question.

    Anyone else have this issue?
     
  20. Nevermind. Found that Premiere Pro 7.0 was listed as an "Aggregate Device" in Output. Went to Audio MIDI Setup, and deleted everything except internal speakers, mic, and Razer device.

    That fixed the problem, in case anyone has the same issue.
     
Thread Status:
Not open for further replies.
Sign In with Razer ID >


Don't have a Razer ID yet?
Get Razer ID >